Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дана строка, состоящая из латинских строчных букв, заменить их аналогичными прописными буквами. Pascal ABC

10-11 класс

Мирослава666 28 нояб. 2013 г., 16:13:25 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
W1999w
28 нояб. 2013 г., 18:50:41 (10 лет назад)

var s:string;
i:integer;
begin
readln(s);
for i:=1 to length(s) do
if s[i] in ['a'..'z'] then write(chr(ord(s[i])+ord('A')-ord('a')));
end.

+ 0 -
Dan4ik32
28 нояб. 2013 г., 21:35:10 (10 лет назад)

var
  str : string;
begin
  write('Введите строку: ');
  readln(str);
  writeln('Результат: ', str.ToUpper);
end.

Ответить

Другие вопросы из категории

Помогите пожалуйста

Если в слове А его вторую половину, буквы которой образуют слово В, заменить на слово С, то получится слово Д. Слова А и Д- носители информации в компьютерах первых поколений; В- чертёж поверхности Земли; С- элемент матричного принтера.
В ответе запишите через один пробел сначала слово, которое зашифровано буквой А , затем слово, зашифрованное буквой С. Например дискета диск.

Содержимое текстового файла

Ivanov
Pugachov
Sidirov Vasya
Hello world!!!
Что будет на экране если выполнить данный фрагмент программы

Читайте также

Дана стока состоящая из латинских букв,в которой слова разделены пробелами(одним или несколькими).Напечатать те строки,которые отличны от последнего слова

и удовлетворяют след. свойству:
- слово совпадает с начальным отрезком латинского алфавита ('a','ab','abc' и т.д.)

P.s. Только решить её надо не использую строки.Вместо них array of char...
Пример ввода:
writeln('Введите предложение, символ конца - точка');
i := 0;
repeat
inc(i);
read(a[i])
until (a[i] = '.')or(i = n);

Заранее огромное спасибо.

ПАСКАЛЬ. Срочно!

Дана строка, состоящая из русских слов, разделенных пробелами (одним или несколькими). Найти количество слов в строке.



Вы находитесь на странице вопроса "Дана строка, состоящая из латинских строчных букв, заменить их аналогичными прописными буквами. Pascal ABC", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.