Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Могут ли действия в команде ветвления выполняться одновременно? Ответ обоснуйте.

10-11 класс

Anna19812202 20 июля 2013 г., 16:01:47 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
МалыгинаЕлизавета04
20 июля 2013 г., 17:09:31 (10 лет назад)

 Разветвляющийся алгоритм (ветвление) - обеспечивает в зависимости от результата проверки условия (да или нет) выбор одного из вариантов работы алгоритма
В разветвляющем алгоритме действия одновременно выполнятся не могут, т. к зависимости от условия может выполняется либо одна, либо другая последовательность действий.
Например: 

Ответить

Другие вопросы из категории

(PASCAL)

Определите значение переменной с после выполнения следующего фрагмента программы
s:=1;i:=1;
while i<5 do
begin
s:=s+i*(i+1);
i:=i+1;
end;

Прошу объяснить решение подобных программ на данном примере

Восстановить IP-адрес компьютера по фрагментам:

3.212 21 2.12 .42
2.19 .50 5.162 22

Какова мощность алфавита, если информационный вес одного символа составляет 32 бита? При приеме некоторого сообщения получили 10 бит информации.

Сколько вариантов исхода было до получения сообщения? Объем сообщения, содержащего 2048 символов, составил 1/512 часть Мбайта. Каков размер алфавита, с помощью которого записано сообщение? Выяснить, сколько бит информации несет каждое двухзначное число (отвлекаясь от его конкретного числового значения). В книге 512 страниц. Сколько информации содержит сообщение о том, что закладка лежит на какой-либо странице. Для ремонта школы использовали белую, синюю и коричне¬вую краски. Израсходовали одинаковое количество банок белой и синей краски. Сообщение о том, что закончилась банка белой краски, несет 2 бита информации. Синей краски израсходовали 8 банок. Сколько банок коричневой краски израсходовали на ремонт школы? Определить количество информации, получаемое при реализации одного из событий, если бросают несимметричную четырехгранную пирамидку.

Читайте также

1.Напишите команды, которые выполняют следующие действия: а) вывод переменной с ;б) описать переменные а и s целого типа; в) переменной r присваивает

разность чисел p и q.
2.Что будет на экране после выполнения следующих команд: а) Writeln(9); Write(5); Writeln(3); б) Writeln(4*2); Write('5-3'); Writeln('5+1=',5+1);
3.Укажите различия циклов While и Repeat
4.Дана строка. Определить сколько пробелов в этой строке
6.Дано четырехзначное число. Вывести на экран сумму цифр этого числа
7.Найти количество цифр целого числа N
8.Напишите команды, которые выполняют следующие действия: а) ввод переменной d б) описать переменные m и n вещественного типа. в) переменной s присвоить разность чисел p и q
9.Что будет на экране после выполнения следующих команд: Writeln(5-3); Write('5+3'); Writeln('5*4=',5*4);
10.Когда нельзя применять цикл for
11.Дана строка. Определить сколько букв в этой строке
12.Дано трехзначное число. Вывести на экран все его цифры столбиком
13. Найти количество цифр целого числа N(+блок-схема)

Введите три числа. Если они могут быть длинами сторон равнобедренного остроугольного....

Ребят,подскажите пожалуйста как проверить могут ли быть стороны длинами равнобедренного остроугольного треуг. Не могу понять ,как проверить именно на остроугольный треугольник ,в геометрии 0. Помогите пожалуйста

Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если все числа не превышают 30, то выведите их

удвоенное произведение. Если последнее число четно, то выведите произведение первых двух чисел, уменьшенное в 10 раз. Если выполняются одновременно 2 условия, то выведите эти числа без изменения. Иначе, выведите разность первого и последнего чисел.
Решить нужно в С или С++
Заранее спасибо!!!

Пять команд из пяти городов приехали в Екатеринбург для участия в финале олимпиады по информатике. "Откуда вы, ребята?" - спросили организаторы олимпиады

капитанов команд.Вот что они ответили.Андреев: "Я из Екатеринбурга, а Григорьев живет в Омске".Борисов: "В Омске живет Васильев, а я прибыл из Челябинска".Васильев: "Из Екатеринбурга – я, а Борисов – из Перми".Григорьев: "Я прибыл из Омска, а Данилов - из Новосибирска".Данилов: "Да, я действительно из Новосибирска, Андреев живет в Челябинске".Когда организаторы соревнования удивились противоречивости их ответов, ребята объяснили: "каждый из нас высказал одно утверждение правильное, а другое - ложное".Откуда приехали ребята?



Вы находитесь на странице вопроса "Могут ли действия в команде ветвления выполняться одновременно? Ответ обоснуйте.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.