Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите)) Дано вещественное число A и целое число N (> 0). Вывести все целые степени числа A от 1 до N.

5-9 класс

Wwwnatusik98 11 марта 2017 г., 5:14:56 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Valeria111sos
11 марта 2017 г., 7:41:09 (7 лет назад)

var

  A, r:real;

  N, s:integer;

begin

  s := 1;

  write('a = '); readln(a);

  write('n = '); readln(n);

  r := a;

  while r <= n do

  begin

    writeln(s);

    inc(s);

    r := r * a;

  end;

  if a > n then

    writeln(a , ' в любой степени >= 1 будет больше числа ', n);

end.

   

 

Ответить

Другие вопросы из категории

В некотором государстве есть n городов. Между некоторыми парами городов проложены дороги. Каждая из дорог имеет длину 100 км. Известно, что из любого

города можно добраться по последовательности дорог в любой другой, причём единственным способом.
а) Что можно сказать о числе дорог в таком государстве?
б) Пусть города занумерованы числами от 1 до n, а каждая дорога задаётся двумя числами – номерами городов, которые она соединяет. Напишите на любом известном вам языке программирования программу, которая находит два города, кратчайший путь между которыми имеет наибольшую возможную длину среди всех кратчайших путей в данном государстве.
в) Оцените время работы вашей программы в зависимости от n. Оценку количества действий укажите в комментариях к коду. Может ли существовать алгоритм, который решает задачу оптимальнее? Если да, то постарайтесь его найти.
Ответы на вопросы о количестве действий и существовании оптимального алгоритма напишите в комментариях внутри вашей программы.

Читайте также

Ребята кто разбирается в Pascal ABC помогите пожалуйста Задачи на циклы с параметром 1.Дано вещественное число A и целое число N (> 0).

Вывести A в степени N: An = A•A•...•A (числа A перемножаются N раз). 2.Дано вещественное число A и целое число N (> 0). Вывести все целые степени числа A от 1 до N. 3.Дано вещественное число A и целое число N (> 0). Вывести 1 + A + A2 + A3 + ... + An. ,

1)Определить, является ли числоа делителем числа b. Даны вещественные числа х и у, не равные друг другу. Меньшее из

этих двух чисел заменить половиной их суммы, а большее — их удвоенным произведением.

2)Даны вещественные числа х и у, не равные друг другу. Меньшее из этих двух чисел заменить половиной их суммы, а большее — их удвоенным произведением.

Даны два целых числа А и В (А < В) . Найти произведение всех целых чисел от А до В включительно.

Входные данные: ввести два целых числа А,В (1 <=А,В<=10).
Входные данные: вывести произведение всех целых чисел от А до В включительно.

For4. Дано вещественное число — цена 1 кг конфет. Вывести стоимость 1, 2, …, 10 кг конфет. For7. Даны два целых числа A и

B (A < B). Найти сумму всех целых чисел от A до B включительно.

2) Даны числа от 5 до 78. Заменить все числа кратных 11 на квадрат этого числа.

3) Даны числа от 1 до n. Найти сумму чисел кратных 5, но не кратных 7.
Помогите пожалуйста!!!)))))



Вы находитесь на странице вопроса "Помогите)) Дано вещественное число A и целое число N (&gt; 0). Вывести все целые степени числа A от 1 до N.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.