Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите решить пожалуйста. срочно нужно! Даны три точки А(х1;у1), В (х2;у2) и С (х3;у3). Определить, будут ли они расположены на одной прямой.

5-9 класс

Ибрагим01 02 сент. 2013 г., 9:05:10 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
123незнайка123
02 сент. 2013 г., 10:48:37 (10 лет назад)

var x1,x2,x3,y1,y2,y3: real;

begin

   readln(x1,y1,x2,y2,x3,y3);

   if (x1*y2+x3*y1+x2*y3-x3*y2-x2*y1-x1*y3=0) then

      writeln('Лежат')

   else

      writeln('Не лежат')

end.

 

P.S. Боюсь, не вполне понятно, откуда этот крокодил. На самом деле, это проверка равенства

\dfrac{y_2-y_1}{x_2-x_1}=\dfrac{y_3-y_1}{x_3-x_1}

+ 0 -
Sn0wBall
02 сент. 2013 г., 11:20:12 (10 лет назад)

Да будут расположенны на одной прямой ( надо построить граффик с осями х и у проставить числа и провести линию)

Ответить

Другие вопросы из категории

Жесткий диск пуст и имеет объем 160 Гбайт. Сколько книг, каждая из которых состоит из 1000 страниц, на каждой странице 100 строк, в каждой строке 80

символов, можно записать на такой жесткий диск (каждый символ кодируется од¬ним байтом)?

помогите плиз срочно

ПАСКАЛЬ!

нужно составить программы, чтобы из слова перестройка получить 10 новых слов!
ребята, плиииз(

Читайте также

Составьте программу для решения задачи : при каком значении N произведение станет меньше 0.1

p=1/2*1/4...1/2N;
Турбо паскаль!!!!
знаю задача не очень то и сложно но я забыл как решать такого типа помогите люди пожалуйста срочно нужно

ИНФОРМАТИКА,РЕШИТЬ ЗАДАЧИ ,помогите решить,пожалуйста,хоть несколько!

1.Даны 3 целых числа-А,В,С. Вычислить их сумму и произведение
2.Вывести на экран случайное число от 0 до 10
3.Вывести на экран двузначное случайное число
4. Найти сумму цифр двузначного числа

1. Определить принадлежит ли введенное с клавиатуры число интервалу (0,5)
2.Ввести число с клавиатуры. Если оно положительно,то найти квадрат этого числа,если отрицательно-модуль.
3.Найти большее из двух чисел ,заданных случайным образом из интервала [-7;23]
4.Ввести двузначное число с клавиатуры. Четна ли сумма его цифр?
5. Ввести трехзначное число. Расположить цифры в порядке возрастания

P.S решить задачи 1. мальчик может бегать в три раза быстрее,чем ходить .Скорость его ходьбы составляет 4км/ч. Он принял участие в марафонском

забеге, но сошел с дистанции, пробежав X км. Сколько времени он затратил но преодоление этой дистанции?

2.Даны две точки на плоскости (х1 ; у1) и (х2; у2). Необходимо определить какая из точек находится дальше (ближе) от начала коорддинатных осей.

3. Написать программу, распознающую по длинам сторон среди всех треугольников прямоугильные.

4. Определить в вещественном числе количество цифр до запятой.

5. В линейной таблице из 16 элементов все числа хранятся в порядке возврастания. Необходимо все числа в таблице расположить в порядке убывания

информатика 9 класс. тема: проверка условий в паскале

координаты а(х1;у1) в(х2;у2) . Какая из точек ближе к началу координат. НАйти расстояние. Напишите пожалуйста программу и если можете еще схему. ХЕЛП



Вы находитесь на странице вопроса "Помогите решить пожалуйста. срочно нужно! Даны три точки А(х1;у1), В (х2;у2) и С (х3;у3). Определить, будут ли они расположены на одной прямой.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.