Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Народ,помогите с этими задачами!уже всю плешь они проели мне!Язык программирования-Pascal.Пишем задачи на Free Pascal

10-11 класс

Aleksandra171 15 февр. 2014 г., 9:17:58 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vikkytikki
15 февр. 2014 г., 11:42:44 (10 лет назад)

1)
Const N = 10;
Var i,S:integer; m:array [1..N] of integer;
Begin       
 randomize;
S:=0;       
for i:=1 to N do begin       
m[i]:=random(118)-58;       
if m[i] mod 5 = 0 then
S:=S+m[i];       
end;       
writeln(S);       
readln;       
end.

Ответить

Другие вопросы из категории

По краю очень большого круглого стола с равными интервалами разложены небольшие конверты, в каждом из которых лежат деньги. Известны суммы, лежащие в

каждом конверте. Опишите алгоритм, позволяющий провести прямую через центр стола, разделяющую конверты на два множества с одинаковой суммой денег. Прямая не должна проходить по конвертам. Если такой прямой нет – сообщите об этом.

написать программу,вычисления в ПАСКАЛЕ , ПОМОГИТЕ ПОЖАЛУЙСТА!

Вывести на печать значения функции z=x²+y+sin(x) при изменении

Читайте также

Помогите решить!!! Уже всю голову сломал, думая над этой задачей.

Если город представить в виде двумерного массива, то получается, что в каждом квартале (ячейке массива) может стоять либо Маша, либо камера (или несколько камер). Посчитать манхтэнское расстояние(сумма расстояний от Маши до всех камер) по формуле:
R= |x1-x2|+|y1-y2|.
Первоначальные координаты Маши (0,0).
Формат ввода:
Первая строка содержит N кол-во камер в городе и M шагов Маши. Вторая строка - координаты камер (х,y).
Для описания передвижения Маши с клавиатуры вводится символы U,D,R,L. Каждый из них означает:
U- увеличить координату у на 1.
D - уменьшить эту же координату.
L - уменьшить координату х.
R - увеличить координату х.
Выводить манхтэнское расстояние для каждого шага Маши.
Пример:
Ввод:___ Вывод:
1 3_______11
0 -10_____12
RUR _____13

Помогите, пожалуйста, решить задачи.

1. В один из жарких летних дней Петя и его друг Вася решили купить арбуз. Они выбрали самый большой и самый спелый, на их взгляд. После недолгой процедуры взвешивания весы показали w килограмм. Поспешно прибежав домой, изнемогая от жажды, ребята начали делить приобретенную ягоду, однако перед ними встала нелегкая задача. Петя и Вася являются большими поклонниками четных чисел, поэтому хотят поделить арбуз так, чтобы доля каждого весила именно четное число килограмм, при этом не обязательно, чтобы доли были равными по величине. Ребята очень сильно устали и хотят скорее приступить к трапезе, поэтому Вы должны подсказать им, удастся ли поделить арбуз, учитывая их пожелание. Разумеется, каждому должен достаться кусок положительного веса.
Входные данные
В первой и единственной строке входных данных записано целое число w (1 ≤ w ≤ 100) — вес купленного ребятами арбуза.
Выходные данные
Выведите YES, если ребята смогут поделить арбуз на две части, каждая из которых весит четное число килограмм, и NO в противном случае.
Примечание
Например, ребята могут поделить арбуз на две части размерами 2 и 6 килограммов соответственно (другой вариант — две части 4 и 4 килограмма).

2. На клетчатой плоскости заданы координаты K зданий. Требуется построить кольцевую дорогу вокруг зданий минимальной длины в виде прямоугольника, со сторонами, параллельными линиям сетки.
Входные данные
Во входном файле, на первой строке, находится число K( ). На следующих K строках находятся пары чисел и – координаты зданий
( ).
Выходные данные
Выведите в выходной файл координаты левого нижнего и правого верхнего углов прямоугольника.

3. Хакер Иван является сотрудником крупной антивирусной компании. Один из вирусов исследованием, которого он занимается, был специально создан для атаки на программы биржевой торговли.
Для того что бы победить зловред Ване необходимо разработать алгоритм, который бы вычислил минимальное количество операций необходимых для того что бы пара чисел (a, b) стала "k -красивой". Пара чисел (a, b) называется "k-красивой" если хотя бы одно из чисел парны не меньше заданного целого числа k. При этом, операции, проводимые с парой чисел (a, b) могут быть только такие:
1. Пара (a, b) может быть преобразована в (a+b, b);
2. Пара (a, b) может быть преобразована в (a, b+a).
Помогите Ване победить.
Входные данные
Единственная строка входных данных содержит три целых числа a, b и k ( - 1018 ≤ x, y, m ≤ 1018).
Выходные данные
Выведите минимальное количество операций или число -1, если сделать заданную пару "k-красивой" невозможно.

4. Инженер-программист Надежда занимается разработкой компилятора для нового сверх секретного языка программирования. Для того чтобы закончить разработку одного из модулей ей остается решить задачу следующего содержания:
Во входных данных Надя получает строку содержащую в себе цифры и скобки одного вида: '(' и ')'. Наде необходимо написать программу, которая для любых входных данных определяет является ли содержащаяся в них скобочная последовательность правильной, и в случае правильности скобочной последовательности возвращает количество встречающихся в ней скобок, если же последовательность неправильная, то выводится число -1.
Скобочная последовательность называется правильной, если:
1. Пустая строка — правильная скобочная последовательность;
2. Правильная скобочная последовательность, взятая в скобки одного типа — правильная скобочная последовательность;
3. Правильная скобочная последовательность, к которой приписана слева или справа правильная скобочная последовательность — тоже правильная скобочная последовательность.
Помогите Наде в разработке компилятора для нового сверх секретного языка программирования.
Входные данные
Единственная строка конечной длины содержит цифры и скобки, длина строки не больше 1024 символов.
Выходные данные
Выведите количество скобок если скобочная последовательность правильная или число -1 если нет.

5. Маленький Вася научился считать сумму цифр для любого числа. Для любого числа, он считал сумму его цифр, затем тоже самое он делал с полученным в результате числом и так далее. Определите сколько раз Васе необходимо посчитать сумму, чтобы она стала цифрой.
Входные данные
Одна непустая строка с числом (0 Выходные данные
Одна строка, с числом.

Народ, помогите, надо написать программу. Язык - на ваше усмотрение. Заранее спасибо, если кто поможет)

Даю чёткое ТЗ:
Шаг 1: У нас есть поле, в котором необходимо указать количество возможных событий (лучше это поле подписать рядом), после ввода туда нужного числа переходим к шагу 2.
Шаг 2: Далее идут поля под события и их процентную вероятность(тоже можно подписать рядом знаком"%"), то биш одно большое и одно маленькое поле на каждую строчку. Количество занятых строчек зависит от количества событий, введенных нами в шаге 1. Теперь вводим в большие поля названия событий (допустим: "дождь", "солнце", "ветер"), а в малые поля вводим их процентную вероятность (допустим "15", "73", "12"). Затем нажимаем кнопку снизу "результат" и под этой кнопкой появится выпавшее событие. При повторном нажатии данной кнопки, ситуация повторяется и нам снова выпадает какое-то событие.

Пример 1:
Количество событий: 3
ОК
Солнечно: 60 %
Ветренно: 25 %
Дождливо: 15 %
Результат
(тут будет написан результат)

Пример 2:
Количество событий: 2
ОК
Попадание: 60 %
Промах: 40%
Результат
(тут будет написан результат)



Вы находитесь на странице вопроса "Народ,помогите с этими задачами!уже всю плешь они проели мне!Язык программирования-Pascal.Пишем задачи на Free Pascal", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.