Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Составить программу,которая запрашивает число и сообщает количество в рублях Пример: 12(вводишь) 12 рублей(получаешь)

5-9 класс

Mberkoru 11 дек. 2014 г., 13:39:02 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tani9696
11 дек. 2014 г., 14:18:59 (9 лет назад)

var n:integer;
begin
read(n);
writeln(n,' Rublei');
end.

+ 0 -
ProActive
11 дек. 2014 г., 15:42:31 (9 лет назад)

var
  R:integer;
begin
  write('Введите сумму ');
  readln(R);
  if (R mod 100 > 10) and (R mod 100 < 20) then {если число заканчивается на 11-19, то дописываем "рублей"}
  writeln(R, ' рублей')
  else {иначе}
    if R mod 10 = 1 then {если число заканчивается на 1, то дописываем "рубль"}
      writeln(R, ' рубль')
    else
      if (R mod 10 > 1) and (R mod 10 < 5) then {если число заканчивается на 2-4, то дописываем "рубля"}
        writeln(R, ' рубля')
      else
        writeln(R, ' рублей'); {если число заканчивается на 5-9 или 0, то дописываем "рублей"}
end.

Ответить

Другие вопросы из категории

РЕШИТЕ ПОЖАЛУЙСТА!!!!!!!!!! Посудина цилиндрической формы заполнена до краёв водой, d=1200кг/м3. Составить программу которая

вычисляет:

а)давление жидкости на дно посудины по формуле p=dgh(g=9,8м/с2)

б)массу жидкости в каждой посудине m=dV=dhS (S=3,14R2)

в) сумарную массу жидкости

Радиус посудины,высоту столба жидкости нужно вводить с клавиатуры,а результат вывести на экран.

СПАСИБО))))))))

Читайте также

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.

5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.
б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.
5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева
б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.
6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.
б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.
напишите хоть какое нибудь нужно к завтрому срочно

A) Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и находит сумму элементов с четными значениями

и количество элементов с нечетными значениями.

б) Составьте программу, которая заполняет массив b[1..8] случайными целыми числами в диапазоне от 1 до 10 и находит произведение элементов с нечетными значениями и количество элементов с четными значениями.

1)составьте программу,которая заполняет массив a[1..10] случаынми целыми числами в диапазоне от 0 до 10 и находит минимальный элемент массива среди

элементов с нечётными индексами

2)составьте программу,которая заполняет массив a[1..10]случайными целыми числами в диапазоне от 0 до 10,находит максимальный элемент массива,а затем вычисляет,сколько раз он встречается в массиве



Вы находитесь на странице вопроса "Составить программу,которая запрашивает число и сообщает количество в рублях Пример: 12(вводишь) 12 рублей(получаешь)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.