Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Народ,помогите дорешать задачу на С++,буду благодарен.

10-11 класс

- В целочисленном массиве Х(N) удалить все элементы, расположенные между максимальным и минимальным элементами.
- Найти среднее арифметическое элементов массива до и после удаления.
- В программе написать функции: удаления элемента, поиска номеров минимального и
максимального элементов, определения среднего арифметического
элементов массива.

из выше перечисленного выводит только средне арифметическое и средне арифметическое между 1 и последним числом.




#include
float srednee(int* a, int min, int max)
{
int s = 0;
for(int i = min; i <= max; i++)
s += a[i];
return s * 1.0 / (max - min + 1);
}
using namespace std;
int min_i(int* a, int n)
{
int m = a[0];
int numb = 0;
for(int i = 1; i < n; i++)
if(m > a[i])
{
m = a[i];
numb = i;
}
return numb;
}
int max_i(int* a, int n)
{

int m = a[0];


int numb = 0;
for(int i = 1; i < n; i++)
if(m < a[i])
{
m = a[i];
numb = i;
}
return numb;
}
using namespace std;
int main()
{
int N;
cin >> N;
int X[N];

for(int i = 0; i < N; i++)
cin >> X[i];
cout << "srednee znachenie vsego massiva: " << srednee(X, 0, N - 1) << endl;
int min = min_i(X, N);
int max = max_i(X, N);
if(min > max)
{
int z = min;
min = max;
max = z;
}
if(max - min == 0 || max - min == 1)
cout << "srednee znachenie korotkogo massiva: " << srednee(X, 0, N - 1) << endl;
else
{
int delta = max - min;
for(int i = max; i < N; i++)
X[i - delta + 1] = X[i];
cout << "srednee znachenie korotkogo massiva: " << srednee(X, 0, N - delta) << endl;
system("pause");
return 0;
}
}

Veroniq 25 апр. 2015 г., 10:29:37 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Katysolnze
25 апр. 2015 г., 11:18:21 (9 лет назад)

Сделал пока часть, остальное завтра допишу

+ 0 -
Assss12
25 апр. 2015 г., 12:02:59 (9 лет назад)

Что за #include в начале?

+ 0 -
89293343820
25 апр. 2015 г., 13:52:57 (9 лет назад)

#include<iostream>

+ 0 -
Hunter1991
25 апр. 2015 г., 15:22:44 (9 лет назад)

вводится целое число N, затем N целых чисел в массиве Х. Затем подсчитывается среднее по всему массиву. Объявляются переменные min и max - номера минимального и максимального элементов. Но если min > max, то их надо поменять местами. Если min == max или они отличаются на единицу, то ничего удалять не надо, среднее остаётся неизменным. Иначе сдвигаем элементы после min на delta = max - min влево, считаем новое среднее арифметическое

Ответить

Другие вопросы из категории

СРОЧНО!!! Нужно точное решение!!!

определить какое значение имеет true или false?
(-3>=5) or not(7>0) and (0<=3)
при вычислении соблюдать следующий приоритет выполнения операции.
1) выражение заключённые в скобки
2) логическое отрицание
3) логическое умножение
4) логическое сложение, исключающее или
5) операции отношения

Читайте также

Отдаю все баллы. У меня паника. Нужно максимум через 3 часа. Помогите решить задачи на pascal abc.

а первом фото 4 с процедурой, 8 с функцией.

На втором фото 8 с рекурсивной процедурой.

Пожалуйста,помогите решить задачи на Pascale!

1)Составить программу вычисления в двумерном массиве минимального элемента, его номера и замены его на 100
2)Записать в файл последовательность доступа n действительных чисел. Найти разность первого и последнего компонентов файла
3)Составить программу, удаляющую из предложения букву "Е"

Здравствуйте) помогите составить задачи по паскалю)

задачи на такую тему: Составление, ввод, трансляция и
исполнение программ, реализующих
циклические алгоритмы и типовые
операции с одномерными массивами

Помогите написать задачу на паскале

================================================================
В одной берляндской школе появился новый ученик Вася, который очень сильно любил химию. К сожалению для учителя химии, Вася принебрегал техникой безопасности и любил смешивать все реагенты подряд. В кабинете химии находится n реагентов. Каждый реагент характеризуется целым числом - своей опасностью. При смешивании реагентов действовали такиме правилами:

смешивать можно только 2 реагента;
при смешивании реагентов, старые реагенты исчезали и появлялся новый реагент, опасность которого равнялась среднему арифметическому старых.

Известно, что Вася собирается смешивать реагенты до тех пор, пока не останется 1 реагент. Помогите учителю химии определить максимально возможную опасность окончательного реагента.

Народ,помогите написать программу на dev c++,объяснить)

В отчете предоставить блок-схемы всех
функций, текст программы.

Задача : В целочисленном массиве Х(N) удалить все элементы, расположенные
между максимальным и минимальным элементами. Найти среднее
арифметическое элементов массива до и после удаления. В программе
написать функции: удаления элемента, поиска номеров минимального и
максимального элементов, определения среднего арифметического
элементов массива.



Вы находитесь на странице вопроса "Народ,помогите дорешать задачу на С++,буду благодарен.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.