Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

привет всем!! помогите пожалуйста,времени мало.. дано целое число m>1. получить наибольшее целое k, при котором 4^k(четыре в степени k)<m.

5-9 класс

пожалуйста с комментариями в паскале,тк надо написать еще математический метод решения в ворде а я не очень в этом))

Foma8585 01 окт. 2014 г., 18:52:08 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lfatkulayeva
01 окт. 2014 г., 19:24:43 (9 лет назад)

4^k < m.

представим m как 4^log(4)m. (Это выражение равно m (по основному логарифмическому тождеству), 4 - основание логарифма).

4^k < 4^log(4)m.

k < log(4)m.

 

Т.е по идее получается, что наибольшее целое k =  log(4)m с отбрасывание дробной части.

 

Сам код:

 

var m:integer; k:real;
begin
write('m = ');
readln(m);
k:=ln(m)/ln(4); {вычисляем логарифм m по основанию 4}
write('k = ',int(k)); {выводим целую часть}
end.

Ответить

Другие вопросы из категории

Пожалуйста помогите решить задачу.

Информационный объем сообщения содержит 1024 символов составляет 1Кбайт.Каким количеством бит кодируется каждый символ этого сообщения?
варианты решения
1.32
2.16
3.8.
4.4
напишите решени

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3. Программа получает на вход количество чисел в

последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число – сумму чисел, кратных 3. входные данные:3,12,25,9 выходные 21

Читайте также

Ребята кто разбирается в Pascal ABC помогите пожалуйста Задачи на циклы с параметром 1.Дано вещественное число A и целое число N (> 0).

Вывести A в степени N: An = A•A•...•A (числа A перемножаются N раз). 2.Дано вещественное число A и целое число N (> 0). Вывести все целые степени числа A от 1 до N. 3.Дано вещественное число A и целое число N (> 0). Вывести 1 + A + A2 + A3 + ... + An. ,

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

1.Дано целое число N.Написать программу ,увеличивающую число в 3 раза ,если оно больше нуля

2.Дано целое число N.Написать программу ,заменяющую его нулём ,если больше или равно нулю,и увеличивающая его в 2 раза ,если число меньше нуля.
3 .Дано целые числа a и b .Написать программу , которая выводит сначала большее число ,затем меньшее.
4.Даны числа a,b,c.Написать программу ,выводящую их в возрастающем порядке.
ПЛИЗ ПОМОГИТЕ

привет,помогите пожалуйста решить еще задачки))))

1)дано натуральное число N>1.найти количество его делителей
2)дано натуральное число N>1.равно ли оно сумме своих делителей(включая единицу,но не себя)
3)даны числа a и n.вычислить:1/a 1/a*a 1/a*a*a ... 1/a*n
это все цикл for,зарание спасибо!



Вы находитесь на странице вопроса "привет всем!! помогите пожалуйста,времени мало.. дано целое число m&gt;1. получить наибольшее целое k, при котором 4^k(четыре в степени k)&lt;m.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.