Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

дана последовательность чисел содержится 1-но отрицательное число найти сумму элементов этой последовательности до 1-го отрицательного числа решите

5-9 класс

пожалуйста )))

Muradov12549 11 февр. 2017 г., 11:13:27 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
123456789089
11 февр. 2017 г., 13:24:10 (7 лет назад)

var a,s:integer;
begin
a:=0;
while a>=0 do begin
read(a);
if a>0 then s+=a;
end;
writeln(s);
end.

Ответить

Другие вопросы из категории

Помогите плииз!! 15 баллов!!!!!
Как десятичное число

123_{10} будет представлено в памяти компьютера???

Ребятаа, помоги прошу. Самостоятельная:(

1.даны два числа m n. большее из этих чисел уменьшить на 3, а меньшее удвоить. составьте алгоритм.
2. составьте алгоритм попадания точки в третью четверть окружности.

Читайте также

Ребятки!!!!ПОмогите пожалуйста очень срочно!!!! Дан файл f компоненты которого действительные числа.Найти сумму компонентов

файла.Результат поместить в файл g.

дан файл f компоненты которого являются целыми числамию Найти наибольший и наименьший из компонентов файла.результат поместить в файл g

ДАн файл f компоненты которого являются целыми числами найти количество чётных чисел среди компонентов.результат поместить в файл g

Дан файл F компоненты которого являяются целыми числами.записать в файл g все чётных числа файла f

Дан файл F компоненты которого являяются целыми числами переписать компоненты файла f в файл g,так чтобы в файле сначала шли отрицательные а потом положительные числа.

1)дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов

2)Дан массив целых чисел.Найти сумму четных положительных чисел, стоящих на нечетных местах и количество отрицательных элементов, стоящих на четных местах.
3)дан массив целых чисел.найти сумму четных и положительных элементов, расположенных до первого отрицательного элемента.Примечание:при вводе необходимо учесть, что первый элемент не может быть отрицательным.

1)найти сумму первых k последовательных нечетных чисел. написать программу в паскале. 2)вывести на экран натуральные нечетные числа от 5 до 55.тоже

паскаль 3)найти произведение последовательных натуральных чисел от n до m. написать программу паскаль. 4)найти сумму последовательных натуральных чисел от 10 до 15.тоже паскаль

1.С клавиатуры вводится 3 числа. Найти сумму только из положительных чисел.

(Тема:Программирование ветвлящихся и цепленных алгоритмов)
2.Дано двухзначное число,найти сумму и произведение его чисел.
(2-ая задача решается с div и mod)
(Тема:Программирование ветвлящихся и цепленных алгоритмов )

Заполните массив с клавиатуры целыми числами и найдите сумму элементов массива с i1-го по i2-й (i1 и i2 вводить с клавиатуры).

Входные данные:
в первой строке целое число n (0 < n ≤ 100) - кол-во элементов в массиве и целые числа i1 и i2 (0 < i1, i2 ≤ 100). Во второй строке целые числа Х1, Х2,..,Хn разделенные пробелом (числа по модулю не превосходят 32000) - значения элементов массива.

Выходные данные:
сумма элементов массива c номерами от i1 до i2.

(Написать программу на Паскале)



Вы находитесь на странице вопроса "дана последовательность чисел содержится 1-но отрицательное число найти сумму элементов этой последовательности до 1-го отрицательного числа решите", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.