Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

С помощью Паскаля:

5-9 класс

1.Заполните массив случайными числами в интервале [0;100] и подсчитайте отдельно среднее значение всех элементов,которые меньше 50, и среднее значение всех элементов,которые больше или равны 50.
2.Заполнить массив случайными числами в интервале [0;5]. Определить, есть ли в нем элементы с одинаковыми значениями,стоящие рядом.
3. Заполнить массив случайными числами и выполнить реверс отдельно в первой половине и во второй половине.

анжеличка123 28 авг. 2014 г., 14:58:39 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Anonimochka7164
28 авг. 2014 г., 16:00:38 (9 лет назад)

1. var a1, a2, b1, b2, c, i, n :integer;
         s:array [1..10000] of integer;
begin
   read (n);
   for i:=1 to n do
   begin
      s[i]:=random(100);
      if s[i]<50 then
      begin
         a1:=a1+s[i];
         a2:=a2+1;
      end;
      if s[i]>=50 then
      begin
         b1:=b1+s[i];
         b2:=b2+1;
      end;
   writeln (a1/a2:0:3,' ', b1/b2:0:3);
end.

2. var a1, a2, b1, b2, c, i, n, j :integer;
         s:array [1..10000] of integer;
begin
   read (n);
   for i:=1 to n do
      s[i]:=random(5);
   for i:=1 to n do
   for i:=1 to n do
      for j:=1 to n do
         if (s[i]=s[j]) and (abs(i-j)=1) then inc(c);
   if c>=1 then writeln ('Есть') else writeln ('Нет');
end.

3.    var a1, a2, b1, b2, c, i, n :integer;
         s:array [1..10000] of integer;
begin
   read (n);
   for i:=1 to n do
      s[i]:=random(127998)-63999;
   a1:=n div 2;
   for i:=1 to a1 div 2 do
   begin
      a2:=s[i];
      s[i]:=s[a1 + 1 - i];
      s[a1  + 1 - i]:=a2;
   end;
   for i:=a1+1 to a1+a1 div 2 do
   begin
      a2:=s[i];
      s[i]:=s[n + 1 - i + a1];
      s[n + 1 - i + a1]:=a2;
   end;
   for i:=1 to n do
      write (s[i],' ');
end.      

+ 0 -
Misyurina02
28 авг. 2014 г., 16:57:16 (9 лет назад)

Что вы понимаете под реверсом и какая половина? по количество или по значению?

+ 0 -
яныш
28 авг. 2014 г., 19:43:47 (9 лет назад)

реверс массива: for i:=1 to N div 2 do c:=A[i];

+ 0 -
Aimira21
28 авг. 2014 г., 21:26:26 (9 лет назад)

реверс массива: for i:=1 to N div 2 do c:=A[i]; A[i]:=A[N+1-i];

+ 0 -
IeroY
28 авг. 2014 г., 22:12:38 (9 лет назад)

а половины,это то есть массив: 1 2 3 4 5 6 а теперь поменяем местами по половине: 3 2 1 6 5 4

+ 0 -
Krokoko7
29 авг. 2014 г., 1:06:58 (9 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

ЯЗЫК QBASIC !!! Решите задачи, используя цикл while-wend 1. Написать программу, вычисляющую сумму и среднее арифметическое последовательности

положительных чисел, которые вводятся с клавиатуры. 2. Написать программу, которая определяет максимальное число из введенной с клавиатуры последовательности положительных чисел (длина последовательности неограниченна).

Читайте также

Помогите, с помощью паскаля надо сделать следующее:

Составить программу, решающую следующую задачу: дано трехзначное число. В нем зачеркнули первую цифру слева и приписали ее справа. Вывести полученное число.
Так же:
Составить программу, решающую следующую задачу: дан номер некоторого года (целое положительное число). Определить соотв-щий ему номер столетия, учитывая, что, к примеру, началом 20го столетия был 1901 год. Сам то я знаю как решать, но не смогу записать это в паскаль!

Помогите решить задачи с помощью Паскаля:

1. В массиве все отрицательные элементы переместить в начало массива, а остальные в конец с сохранением порядка следования.
2. Дана последовательность целых чисел, среди чисел есть одинаковые, создать массив различных чисел последовательности и полученный массив отсортировать по возрастанию.

Решить задачи с помощью Паскаля:

1. Заполнить массив из 10 элементов случайными числами в интервале [0..100] и отсортировать его по последней цифре.
2. Заполнить массив из 10 элементов случайными числами в интервале [0..100] и отсортировать первую половину по возрастанию, а вторую- по убыванию. Здесь решать лучше методом выбора.



Вы находитесь на странице вопроса "С помощью Паскаля:", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.