Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

дан массив А из 20 целых элементов расположенных в промежутке от -10 до 10.найти СУММУ положительных элементов этого массива

5-9 класс

ЛеДиNiKe 02 сент. 2014 г., 10:28:45 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Филипп0001
02 сент. 2014 г., 12:31:54 (9 лет назад)

program massiv;

const N=20;

var a:array [1..N] of integer; i,m,k:integer;

begin

m:=0;

for i:=1 to N do

readln(a[i]);

for i:=1 to N do

if a[i]>=0 

then m:=m+a[i];

writeln('Otvet ',m);

end.

 

недавно такую же задачу другой человек спрашивал...

Ответить

Другие вопросы из категории

Помоги пожалуйста решить задачу))

Очень надо

ПОМОГИТЕ ПОЖАЛУЙСТА РЕШИТЬ

2) При задании или объединении группы файлов по именным признакам во многих системах используют, так называемые, шаблоны или маски файлов, которые включают в себя совпадающие части имен этих файлов и специальные символы "*" и "?". Символ "*" обозначает, что на его месте, где находится спецсимвол, может присутствовать любое количество любых символов, в том числе их может и не быть. Символ "?" обозначает, что на его месте может находиться любой одиночный символ. Имя файла состоит из двух частей: самого имени и расширения, которые разделяются точкой. Используя правила создания шаблонов файлов, определите, какой из перечисленных файлов подойдет под все предложенные маски:
*12*3.d*?
?123*.do*
*?12?.???
а?23*.*
l)aal23.do 2)al233.dot 3) a223123.doc 4) al23.doc
3) В каталоге находятся файлы со следующими именами:
file.mdb
file.mp3
ilona.mpg
pile.mpg
miles.mp3
nil.mpeg
Определите, по какой из масок будет выбрана указанная группа файлов:
file.mp3
pile.mpg
miles.mp3
nil.mpeg
1) ?il*.m* 2) ?il*.mp* 3) *il?.mp* 4) ?il*.mp?
4) В каталоге находятся файлы со следующими именами:
bike.mdb
bike.mp3
iks.mpg
like.mpg
mikes.mp3
nike.mpeg
Определите, по какой из масок будет выбрана указанная группа файлов:
bike.mp3
like.mpg
mikes.mp3
nike.mpeg
1) ?ik*.m* 2) ?ik*.mp? 3) *ik?.mp* 4) ?ik*.mp*

Читайте также

Решить задачи на языке программирования в Turbo Pascal: 1) Дан массив, состоящий из 10 чисел, значения могут быть

от -100 до 100. Определить минимальное положительное число.

2) Дан массив, состоящий из 10 чисел. Найдите номера тех элементовв масива, которые наименее различаются.

1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива.

2. Создать массив A из 10 элементов, заполненный случайным образом числами принадлежащих промежутку (0;20). Вывести полученный массив на экран. Вычислить количество элементов массива, значения которых не превышают среднее арифметическое значений его элементов.

1)дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов

2)Дан массив целых чисел.Найти сумму четных положительных чисел, стоящих на нечетных местах и количество отрицательных элементов, стоящих на четных местах.
3)дан массив целых чисел.найти сумму четных и положительных элементов, расположенных до первого отрицательного элемента.Примечание:при вводе необходимо учесть, что первый элемент не может быть отрицательным.

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.



Вы находитесь на странице вопроса "дан массив А из 20 целых элементов расположенных в промежутке от -10 до 10.найти СУММУ положительных элементов этого массива", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.