Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Даны три вещественных числа x,y,z. Вычислить значения выражений x+y+z и xyz и вывести максимальное из них.

1-4 класс

Тиимыч 30 окт. 2016 г., 5:54:47 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
72742
30 окт. 2016 г., 6:54:01 (7 лет назад)

var x,y,z,sum,pr:real;
begin
readln(x,y,z);
sum:=x+y+z;
pr:=x*y*z;
if (sum>pr) then
writeln(sum)
else
writeln(pr);
end.

Ответить

Другие вопросы из категории

Читайте также

Дано три числа - длина стороны квадрата и длины сторон прямоугольника. Определить, можно ли прямоугольник поместить в квадрат.

Входные данные:
Во входном потоке задано три вещественных числа - сторона квадрата и стороны прямоугольника соответственно. Значение всех исходных величин не превышает 30000.

Выходные данные:
В выходной поток вывести 'YES' или 'NO'.

Пример входного файла
5 4 5
Пример выходного файла
YES

Даны три вещественных числа x, y, z. Вычислить значения выражений x

+y+z и xyz и вывести максимальное из них

Напишите программу, которая вводит два вещественных числа, a и b ( a < b ), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a ,

b ) .

Входные данные
Входная строка содержит два вещественных числа a и b , разделённых пробелом. Гарантируется, что a < b .

Выходные данные
Нужно вывести в одной строке через пробел 5 случайных вещественных чисел в полуинтервале [ a , b ) с тремя знаками в дробной части.



Вы находитесь на странице вопроса "Даны три вещественных числа x,y,z. Вычислить значения выражений x+y+z и xyz и вывести максимальное из них.", категории "информатика". Данный вопрос относится к разделу "1-4" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.