Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

составить программу. 1)дан массив х(1..10) получить новый массив у(1..10) такой что в нем сначала идут положительные числа, нулевые

10-11 класс

,отрицательные.(из х массива) 2)найти минимальный элемент массива х(1..10)и максимальный элемент массива.поменять их местами и вывод результирующего массива на экран

Kochegarovasve 05 июня 2013 г., 12:41:02 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Helen1689
05 июня 2013 г., 14:58:48 (10 лет назад)

type array100 = array [1..100] of integer;
var x,y:array100;
i,n,min,max:integer;

procedure QuickSort(var a:array100;low:integer;high:integer);
var i,j,x,t:integer;
begin
  i:=low;
  j:=high;
  x:=A[(low+high) div 2];
 
  repeat
    while(A[i]>x) do
      i:=i+1;
    while(A[j]<x) do
      j:=j-1;
    if(i<=j) then begin
      t:=A[i];
      A[i]:=A[j];
      A[j]:=t;
      i:=i+1;
      j:=j-1;
    end;  
  until (i>j) or (i>=n);
 
  if(low<j) then QuickSort(A,low,j);
  if(i<high) then QuickSort(A,i,high);
end;

Begin
  randomize;
  n:=20;
  for i:= 1 to n do begin
    x[i]:=random(n*10)- 10*n div 2 ;
    write(x[i]:4);
    y[i]:=x[i];
    if i mod 10=0 then writeln;
  end;
 
  QuickSort(y,1,n);
 
  writeln;
  for i:= 1 to n do begin
    write(y[i]:4);
    if i mod 10=0 then writeln;
  end;
  {second part}
  min:=1;
  max:=1;
  for i:= 1 to n do begin
    if x[i]<x[min] then min:=i;
    if x[i]>x[max] then max:=i;
  end;
  i:=x[min];
  x[min]:=x[max];
  x[max]:=i;
    
  writeln;
  for i:= 1 to n do begin
    write(x[i]:4);
    if i mod 10=0 then writeln;
  end;
 
End.

Ответить

Другие вопросы из категории

Докажите тождество. Срочно!!!
Паскаль!!!

составьте алгоритм для определения количества цифр в записи произвольного натурального числа

Читайте также

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

1)составить программу, организующую массив записей о книгах, ввести информацию по следующим полям:автор, название, год издания. Провести сортировку и

вывести список книг, изданных после 2003 года.



2)составить программу , организующую массив записей о пяти студентах и их оценках по трем предметам. провести сортировку и вывести список отличников.

дан массив из семи элементов написать программу подсчитывающую

среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.



Вы находитесь на странице вопроса "составить программу. 1)дан массив х(1..10) получить новый массив у(1..10) такой что в нем сначала идут положительные числа, нулевые", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.