Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

1.Даны координаты трёх вершин треугольника(x1,y1),(x2,y2),(x3,y3).Найти его площадь,используя формулу для расстояния между двумя точками на

5-9 класс

плоскости.

Пожалуйста помогите,очень надо,успеть до 23.00(

LizaLaim1234 21 февр. 2014 г., 18:40:42 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
милдфорд
21 февр. 2014 г., 20:40:57 (10 лет назад)

Пишите язык, что ли. Хотите получить рано или поздно программу на brainfuck-e?

Я напишу на Паскале.

 

function dist(x1,y1,x2,y2: real): real;

begin

   dist := sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));

end;

var x1,x2,x3,y1,y2,y3,a,b,c,s:real;

begin

   readln(x1,y1,x2,y2,x3,y3);

   a:=dist(x1,y1,x2,y2);

   b:=dist(x1,y1,x3,y3);

   c:=dist(x2,y2,x3,y3);

   s:=(a+b+c)/2;

   s:=sqrt(s*(s-a)*(s-b)*(s-c));

   writeln(s)

end.

 

Ответить

Читайте также

2 задачи по программированию: 1) Три точки заданы своими координатами (x1,y1),

(x2,y2), (x3,y3). Напишите программу, позволяющую выяснить, какие из них находятся на максимальном расстоянии друг от друга, и вывести на печать значение этого расстояния. Вычисление расстояния между двумя точками оформите в виде процедуры.

2) Даны действительные числа Х и Y. Напишите программу, позволяющую вычислить значение следующего выражения:

Z=(signX + signY)*sign(X+Y),

Вычислите расстояние между двумя точками с данными координатами: (x1,y1) и (x2,y2)

Формула для нахождения расстояния: картинка снизу
И всё это в паскаль. Спасибо.

Помогите плиз срочно 1)Написать программу,которая спрашивает"Который час?" и,в зависимости от введенного времени,выводит приветствие:"Доброе

утро","Добрый день","Добрый вечер", "Спокойной ночи". 2)Написать программу,которая определяет,принадлежит ли точка с координатами (x,y)Заштрихованной области,ограниченной точками(x1,y1)(x2,y2).

помогите какие знаете................ прошу помогите плиззз.......................

Решить задачи, составить программы:
1.Найти сумму цифр целого четырехзначного числа, и определить число,
цифры которого записаны в обратном порядку по отношению к исходному.
2.По введенному с клавиатуры аргументу вычислить значение функции.
3.Поменять местами значения двух переменных.
4. Написать программу ввода четырех чисел и вычисления их среднего арифметического.
5. Написать программу для вычисления дискриминанты квадратного уравнения.
6.Из железной полосы длиной L метров нужно изготовить обруч. На
соединение концов уходит D метров полосы. Написать программу вычисления
радиуса обруча.
7.Найти площадь конца, по введенным внешним и внутренним радиусам.
8.Найти расстояние между двумя точками по их координатам



Вы находитесь на странице вопроса "1.Даны координаты трёх вершин треугольника(x1,y1),(x2,y2),(x3,y3).Найти его площадь,используя формулу для расстояния между двумя точками на", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.