Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

1. Даны вещественные положительные числа а,в,с,d. выяснить можно ли прямоугольник со сторонами а,b уместить внутри прямоугольника со сторонами с,d

10-11 класс

так, чтобы каждая из сторон одного прямоугольника былапараллельна или перпендикулярна каждой стороне второго прямоугольника.

Алёнка20000623 31 дек. 2014 г., 5:40:25 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Akondratyuk02
31 дек. 2014 г., 7:22:31 (9 лет назад)

var a,b,c,d:real;

Begin

   read(a,b,c,d);

   if ((a<c) and (b<d)) or ((b<c) and (a<d)) then

     writeln('Впишется')

   else writeln('Не впишется');

End.

 

var a,b,c:real;

Begin

   read(a,b,c);

   if (a>b) and (a>c) then a:= b*c;

   if (b>a) and (b>c) then a:= a*c;

   if (c>b) and (c>a) then a:= b*a;

 

   writeln(a);

End.

3)var x,y,z,u:real;
function max(x,y,z:real):real;
begin
  if (x>=y) and (x>=z) then max:= x;
  if (y>=x) and (y>=z) then max:= y;
  if (z>=y) and (z>=x) then max:= z;
end;

function min(x,y,z:real):real;
begin
  if (x<=y) and (x<=z) then min:= x;
  if (y<=x) and (y<=z) then min:= y;
  if (z<=y) and (z<=x) then min:= z;
end;

Begin
    read(x,y,z);
    u:=(max(x,y,z)*max(x,y,z)-exp(x*ln(2)))/(sin(2*x)+max(x,y,z)/min(x,y,z));
    writeln(u);
End.

 

 

 

Ответить

Другие вопросы из категории

Тут такая Фигня..нужно сделать реферат на тему:"что такое регист?"

Скиньте ссылки пожалуйста,очень выручите

Люди, помогите, пожалуйста!!!

Программа, которая превращает исходный код в машинный код, называется:


1. интерпретатор

2. компоновщик

3. компилятор

4. цекодер

5. дешифратор

Читайте также

Дано целое положительное число. Проверить истинность высказывания: «данное число является нечетным трехзначным».

Входные данные: ввести одно целое положительное число a ((1<=a<=1000).
Выходные данные: вывести слово «true» если приведенное высказывание для предложенных исходных данных является истинным или «false» в противном случае.

Помогите с задачками в паскале. Даны три положительных числа а, в, с. Проверить будут ли они сторонами треугольника. Если да то

вычислить площадь этого треугольника. Даны два действительных положительных числа х и у. Арифметические действия над числами пронумерованы (1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление). Составить программу, которая по выведенному номеру выполняет то или иное действие над числами.

Программирование. Даны три вещественных числа a,b,c. Существует ли треугольник со сторонами a,b,c? program dz1; uses crt; var

a,b,c:integer;

begin

writeln('введите три числа: ');

readln(a,b,c)

а дальше не знаю помогите пожалуйста!!!!)

1) Задано положительное число A. Найти сумм всех четных чисел в интервале от 1 до A. Число А может иметь дробную часть.

2) Задано целое положительное число А и В. Найти квадратные корни целых чисел в интервале от А до В. Замечание: A<B



Вы находитесь на странице вопроса "1. Даны вещественные положительные числа а,в,с,d. выяснить можно ли прямоугольник со сторонами а,b уместить внутри прямоугольника со сторонами с,d", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.