Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

ПОЖАЛУЙСТА, ПОМОГИТЕ, ПАСКАЛЬ, СРОЧНО!

5-9 класс

1. Задать случайным образом 13 элементов числового массива – числа от 10 до 50. Удалить из него:
а) 10-ый элемент;
б) минимальный элемент.

2. Из символьного массива, 7 элементов которого заданы с клавиатуры, удалить максимальный элемент.

Solomonjeui 21 авг. 2014 г., 12:44:40 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Natashamiller
21 авг. 2014 г., 15:37:06 (9 лет назад)

i,k:integer;
begin
randomize;
writeln('Массив:');
for i:=1 to 13 do
begin
a[i]:=random(41)+10;
write(a[i],' ');
end;
writeln;
writeln('Массив после удаления 10-го элемента:');
for i:=10 to 12 do
a[i]:=a[i+1];
for i:=1 to 12 do
write(a[i],' ');
writeln;
writeln('Массив после удаления минимального элемента: ');
k:=1;
for i:=1 to 12 do
if a[i]<a[k] then k:=i;
for i:=k to 11 do
a[i]:=a[i+1];
for i:=1 to 11 do
write(a[i],' ');
writeln;
end.

var
a:array [1..7] of char;
i,k:integer;
begin
writeln('Введите массив:');
for i:=1 to 7 do
readln(a[i]);
writeln('Массив');
for i:=1 to 7 do
write(a[i],' ');
writeln;
writeln('Массив после удаления максимального элемента: ');
k:=1;
for i:=1 to 7 do
if a[i]>a[k] then k:=i;
for i:=k to 6 do
a[i]:=a[i+1];
for i:=1 to 11 do
write(a[i],' ');
writeln;
end.

Ответить

Другие вопросы из категории

РЕБЯТ ПОЖАЛУЙСТА ОЧЕНЬ НАДО! ВЗАМЕН МОГУ РЕШИТЬ ВАШУ ЗАДАЧУ! С клавиатуры вводятся стороны треугольника а, b, c. написать программу , которая в

зависимости от введённых сторон определяет какой треугольник ( равносторонний , разносторонний или равнобедренный ). Можно пожалуйста в Паскале))Заранее спасибочи)))

ПОМОГИТЕ СРОЧНО,ПОЖАЛУЙСТА!!!

Для какого из приведённых имён истинно высказывание:

НЕ(Первая буква гласная) И (Последняя буква гласная)?
Варианты ответов:
Юрий
Николай
Иван
Марина

Читайте также

Пожалуйста помогите по информатике

1) исключи лишнее:
а)микрофон, б)колонки, в) наушники , г) монитор
2)исключи лишнее:
а)процессор, б) монитор, в)клавиатура, мышь
3)установите соответствие. Устройство ПК:
1. клавиатура
2. модем
3.центральный процессор
назначение устройств:
а)передача цифровой информации через каналы связи
б)хранение информации
в)обеспечение общего управления ПК, осуществление вычислений по программе, хранящейся в оперативной памяти
г)визуальное отображение информации, находящейся в оперативной памяти
д)ввод алфавитно-цифровых символов
6.Раздели на группы и дай название каждой группе:
а)принтер,б)сканер,г)мышь,д)проектор,е)веб камера,ж)процессор,з)колонки,и)микрофон, к) монитор
Пожалуйста помогите очень срочно.

Пожалуйста помогите создать какую нибудь полезную программу на паскаль , срочно нужно до понедельника, чтобы в этой программе были все темы за 8 класс,

read.writeln.else.to.if и тд которые сможете
Вот пример идеи для программы, в академию поступают какое то количество учеников, нужно написать сколько учеников сдали документы, сколько пришли на экзамен, и сколько учеников кто прошло и не прошло
возможно не возможно создать программу на этой идее, тогда прделагайте свои со своими программами , пожалуйста помогите!

Пожалуйста, помогите!!!!!!!!!! Известно, что в 12-летнем цикле года носят вои названия: мышь, корова, тигр, заяц, улитка, змея, лошадь, овца,

обезьяна, курица, собака и свинья. Зная, что 1984 год был годом мыши, написать программу, выводящую номер года и его название.

Учитель сказал, что это решается через кейс..Только как.ПОЖАЛУЙСТА, ПОМОГИТЕ!!!!!!!!!!

Ребята Пожалуйста помогите! !!

Нужно написать слово МАМА с помощью команды на вектор
(Пожалуйста напишите координаты) СРОЧНО! !!

ПОЖАЛУЙСТА ПОМОГИТЕ ОЧЕНЬ СРОЧНО! РЕШАЕТСЯ СУДЬБА! ПЛИИИЗ! НА ПОМОЩЬ! В приведенных ниже пословицах и поговорках отдельные слова

или несколько последовательно идущих букв образуют термин, связанный
с информатикой и ИКТ. Искомые термины начинаются на букву, оформленную жирным начертанием. Найдите их. Прокомментируйте найденные термины.

А: Где хотите, там и бранитесь, а на табаке помиритесь.

Б: Умел ошибиться, умей и поправиться.

В: Рожь кормит сплошь, а пшеничка по выбору.

Г: Всякая птица свое гнездо любит.

Д: Широка дорожка Ерошке.

Е: И мед горчит, если его много.

Ж: Ржавое железо не блестит.

З: Если мало в привозе, то много в запросе.

И: Истина выдерживает проверку опытом.

К: Вода размывает канал в слабом месте.

Л: Глупа та птица, которой гнездо свое не мило.

М: На ходу подметки режет.

Н: Где хвост — начало, там голова — мочало.

О: Всякой молодец на свой образец.

П: Закон — что паутина: шмель проскочит, а муха увязнет.

Р: Дело сделал на копейку, а раструбил на всю деревню.

С: Долгие сборы на короткий век.

Т: Юность — время золотое: ест, и пьет, и спит в покое.

У: Шито-крыто, а узелок-то тут.

Ф: Два фонаря на пустой каланче.

Х: Как не хитри, а правды не перехитришь.

Ц: Цветет старость сединою.

Ч: К мягкому воску печать, к молодому – ученье.

Ш: Шумит дубровушка к погодушке.

Щ: Сигарета — щелчок по легким, бутылка пива — удар по почкам,
рюмка водки — убийство печени, кусок сала — прессинг желудка.

Э: Каково эхо, такова и конюшня.

Ю: Верный вассал двум сюзеренам не служит.

Я: Откладывать в долгий ящик.



Вы находитесь на странице вопроса "ПОЖАЛУЙСТА, ПОМОГИТЕ, ПАСКАЛЬ, СРОЧНО!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.