Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите пожалуйста!! Задача по паскалю!

5-9 класс

введите три числа a, b, с. определите количество положительных чисел в данном наборе

Nastye1704 11 февр. 2014 г., 17:34:53 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lici8888
11 февр. 2014 г., 19:44:04 (10 лет назад)

var
  a, b, c: real;
  n: integer;

begin
  Write('Введите через пробел три числа: ');
  Readln(a, b, c);
  if a > 0 then n := 1 else n := 0;
  if b > 0 then n := n + 1;
  if c > 0 then n := n + 1;
  Writeln('Положительных чисел- ', n)
end.

Тестовое решение:
Введите через пробел три числа: -3.54 2.16 4
Положительных чисел- 2


Ответить

Другие вопросы из категории

Для хранения растрового изображения

размером 64 × 128 пикселей отвели 8 Кбайт памяти. Какое
максимально возможное число цветов в палитре изображения?

Читайте также

пожалуйста, помогите решить задачи по Паскалю!!!

1) Даны два числа. Составить алгоритм и перевести его на язык программирования, который меньшее из них возводит в квадрат, а большее оставляет без изменения,

ПОМОГИТЕЕ


помогите пожалуйста задача по информатике if8 паскаль

даны два числа.Вывести в начале большее а затем меньшее.



Вы находитесь на странице вопроса "Помогите пожалуйста!! Задача по паскалю!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.