Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Составить программу:

10-11 класс

сформировать в памяти массив из 15 целых чисел.Изменить массив так,чтобы числа под чётными номерами были удвоены,а на нечётных-заменены нулями.
Пожалуйста!

Vata96 22 дек. 2016 г., 10:25:17 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Makskuz777
22 дек. 2016 г., 13:03:11 (7 лет назад)

var
  a: array [1..25] of integer;

begin
  for i: integer := 1 to 25 do
  begin
    a[i] := random(255);
    writeln(i, ' => ', a[i]);
  end;
  writeln('-----------------------------------');
  for i: integer := 1 to 25 do
  begin
    if (i mod 2 = 0) then
      a[i] := a[i] * 2
    else
      a[i] := 0;
    writeln(i, ' => ', a[i]);
  end;
end.

+ 0 -
Зенитушка
22 дек. 2016 г., 14:28:38 (7 лет назад)

for i:=1 to mass.length do
if(odd(mass[i])) then mass[i]=0
else mass[i]*=2;

+ 0 -
Sanek64rus
22 дек. 2016 г., 16:33:22 (7 лет назад)

воу,это всё?огромнейшее спасибо!

Ответить

Другие вопросы из категории

Информатика помогите решить
Ребят помогите пожалуйста решить задачку на турбо паскале Дан одномернный массив из 10 целых чисел.Вывести массив на экран в строчку.а так же

вывести на экран номер первого элемента, равного нулю, и нуль при отсутсвии такого элемента в массиве.

Ниже приведен рекомендованный вид экрана во время выполнения программы, для самопроверки результата(данные, введенные пользователем, выделены полужирным шрифтом).

Дан одномерный массив сотоящий из 10 элементов.Вывод на экрна номер первого элемента, равного нуляю, и нуль при отсутсвии такого элемента в массиве.

Ввод элеентов массива

Введите 1 элемент массива: 0

Введите 2 элемент массива: 1 и т.д. до 9

Очистка Экрана

0 1 2 3 4 5 6 7 8 9

НОмер нулевого элемента массива: 1

Читайте также

1. Составить программу для нахождения наибольшего числа из трех чисел.

2. Составить программу для упорядоченное двух элементов по убыванию.

1)составить программу, организующую массив записей о книгах, ввести информацию по следующим полям:автор, название, год издания. Провести сортировку и

вывести список книг, изданных после 2003 года.



2)составить программу , организующую массив записей о пяти студентах и их оценках по трем предметам. провести сортировку и вывести список отличников.

помогите составить программу!пожалуйста!!!!ооочень надо

ракета запускается с земли со скоростью V(км час) в направлении движения земли по орбите вокруг солнца. составить программу,определяющую результат запуска ракета в зависимости от скорости V.
Известно,что при V16,4 ракета покинет солнечную систему.

Помогите пожалуйста!! ) составить программу в "Pascal abc"!!)

Составить программу вычисления значений функции F(x) на отрезке [а; b] с шагом h.
Результат представить в виде таблицы, первый столбец которой — значения
аргумента, второй — соответствующие значения функции: "F(x) = 1/2 ctg x/4+4"

Нужно составить программу с предусловием и постусловием!

Составить программу к.т. запрашивает буквы, пока не введут точку и находит количество букв "0".



Вы находитесь на странице вопроса "Составить программу:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.