Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

дана строка символов.Найти количество слов,у которых первый последний символы совпадают между собой

10-11 класс

Artemka3666 25 июня 2014 г., 13:30:40 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kjemikerabuzar
25 июня 2014 г., 16:29:02 (9 лет назад)

uses crt;
var s,sl: string;
i,k: integer;
begin
writeln('Введите строку');
readln(s);
s:=s+' ';
sl:='';
for i:=1 to length(s) do
if s[i]<>' ' then sl:=sl+s[i]
else
begin
if (sl[1]=sl[length(sl)]) and (length(sl)<>0) then inc(k);
sl:='';
end;
writeln('Количество слов, начинающихся и заканчивающихся одной буквой = ',k);
readkey
end.

Ответить

Читайте также

Составить программы: 1.Дана строка символов, среди которых есть двоеточие. Определить, сколько символов следуют за двоеточием.

2.Дана строка символов, среди которых есть одна открывающаяся и одна закрывающаяся скобка. Подсчитать, сколько слов расположено внутри этих скобок.

3.Дана строка. Удалить из нее все запятые и подсчитать, сколько получилось удаленных символов.

Помогите, пожалуйста!

Cтроки. Паскаль. 1.Задано слово - последовательность произвольных символов. Сделать программу, в которой составляется слово перевертыш к данному

( символы записываются в обратной последовательности.)

2.Дана символьная строка. Слово - последовательность символов между пробелами, не содержащая пробелы внутри себя.составить программу, в которой выводились бы все слова, в которых есть заданный символ.

ПАСКАЛЬ. Срочно!

Дана строка, состоящая из русских слов, разделенных пробелами (одним или несколькими). Найти количество слов в строке.



Вы находитесь на странице вопроса "дана строка символов.Найти количество слов,у которых первый последний символы совпадают между собой", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.