Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Составьте программу поиска трехзначных чисел которые при делении на 43 дают в остатке 41 а при делении на 47 дают в остатке 43

10-11 класс

1298verty 11 мая 2014 г., 13:10:56 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Egorborshch
11 мая 2014 г., 15:49:53 (9 лет назад)

А нет таких чисел!

var
  i:integer;
begin
  for i:=1 to 10000 do  // по условиям задачи i:=1 to 999
    if (i mod 43 = 41) and (i mod 47 = 43) then
      writeln(i);
end.

Результаты вывода:
1030
3051
5072
7093
9114

Так что минимальное число, удовлетворяющее требованиям, 1030, но оно не трехзначное

Вот более продвинутый алгоритм, делающий то же самое:

var
  n43:integer;
begin
  n43:=127;
  repeat
    n43:=n43+43;
  until (n43 mod 43 = 41) and (n43 mod 47 = 43); //добавить and (n43<1000)
  writeln(n43)
end.

Результат вывода:
1030

+ 0 -
Seasleeps
11 мая 2014 г., 17:45:48 (9 лет назад)

трехзначных чисел нету таких

Ответить

Другие вопросы из категории

Читайте также

Язык "Паскаль АВС" 1.Среди двухзначных чисел найти количество четных чисел. 2. Среди двухзначных чисел найдите те числа, у которых первая цифра четная.

3. Среди двухзначных чисел найдите те числа, которые кратны 3 и 4. 4. Среди трехзначных чисел найдите те, у которых все цифры равны. 5. Найдите среди трехзначных чисел симметричные числа. 6. Найдите среди четырехзначных чисел симметричные числа. 7. Найдите все трехзначные числа такие, что сумма цифр равна А, а само число делится на В. А и В вводятся с клавиатуры. 8. Найдите все трехзначные числа такие, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, при увеличении на 4 делятся на 5. 9. Найдите количество трехзначных чисел, сумма цифр которых равна А, а само число заканчивается на В, А и В вводятся с клавиатуры. 10. Найдите все трехзначные числа, у которых сумма крайних цифр равна сумме средних цифр, а само число делится на 6 и 27. 11.Найдите все трехзначные числа, которые при делении на 2 дают остаток 1, при делении на 3-остаток 2, при делении на 4-остаток 3, само число делится на5. 12. Найдите все четырехзначные числа, в которых есть две одинаковые цифры. 13. Найдите сумму всех чисел из промежутка от А до В, кратных 13 и 5, А и В вводятся с клавиатуры. 14. Найдите все симметричные четырехзначные числа. 15.Найдите все трехзначные числа, которые состоят из различных цифр, а их сумма равна А.

Ребят помогите ПОЖАЛУЙСТА! не могу решить задачу по информатике. Найти все трехзначные числа, которые при увеличении на 1 делятся на 2, при увеличении

на 2 делятся на 3, при увеличении на 3 делятся на 4, при увеличении на 4 делятся на 5. Буду очень благодарна!!!!

Паскаль

1.Найти все двухзначные числа,такие,что если к сумме цифр числа прибавить квадрат этой суммы,то получится это число.
2.Найти четырехзначное число,которое при делении на 133 дает в остатке 125,а при делении на 134 остаток 111.

1)составьте программу вычисления суммы чисел в диапазоне от 45 до 115 45+....+115

2)Составьте программу которая выводит на экран числа кратные 2 и 13 в диапазоне от 2 до 150
3)Дано вещественное число А и целое число N(>0).Испульзуя один цикл вывести все целые степени числа А от 1 до N

------------------------ОПЕРАТОР WHILE



Вы находитесь на странице вопроса "Составьте программу поиска трехзначных чисел которые при делении на 43 дают в остатке 41 а при делении на 47 дают в остатке 43", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.