Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Разработайте

10-11 класс

алгоритм для сравнения двух целых чисел, введен­ных с клавиатуры, вывести
меньшее число, или, если числа равны, вывести любое из них

OBAY 15 окт. 2016 г., 11:13:58 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
EpifanovaDiana
15 окт. 2016 г., 13:13:17 (7 лет назад)

Вот код программы, я думаю в нём алгоритм видно?)

 int a; int b;           
Console.WriteLine("Введите первое число");   
 a = int.Parse( Console.ReadLine());           ///1)Вводим первое число
 Console.WriteLine("Введите второе число"); 
  b = int.Parse(Console.ReadLine());           ///2) Вводим второе число
 
if (a < b) Console.WriteLine("Меньше а = " + a);    ///3)Сравниваем, если а<b пишем а
if (a > b) Console.WriteLine("Меньше b = " + b);    ///4)Сравниваем, если а>b пишем b
if (a == b) Console.WriteLine("а = b = " + a);          ///3)Сравниваем, если а=b пишем а
       
   Console.ReadLine();

Ответить

Другие вопросы из категории

Помогите пожалуйста задаца 3
Предлагается некоторая операция над двумя произвольными трехзначными десятичными числами:

1) Записывается результат сложения старших разрядов этих чисел.
2) К нему дописывается результат сложения средних разрядов по такому правилу: если он меньше первой суммы, то полученное число приписывается к первому слева, иначе - справа.
3) Итоговое число получают приписыванием справа к числу, полученному после второго шага, сумму значений младших разрядов исходных чисел.
Какое из перечисленных чисел могло быть построено по этому правилу? Почему?
1)91311
2)111319
3)1401
4) 131118

информатика 10 класс..

Составьте программу, которая:
а) определяет коды двух введенных с клавиатуры символов;

Найти сумму пятнадцати нечетных чисел натурального ряда,

начиная с N>0. N вводится с клавиатуры




Читайте также

1. Разработать схему алгоритма для ввода четырёх целых чисел и вычисления их среднего арифметического.

Протестировать алгоритм на различных исходных данных (включая вещественные числа) и доказать правильность его работы.

2. Вводятся величины X,Y целого типа. Разработать схему алгоритма для обмена значений величин. Необходимо использовать вспомогательную величину Т. Протестировать алгоритм для X=5 и Y=-11.

Задание № 1) Разработать блок схему алгоритма, который проверяет, является ли четным введенное с клавиатуры число

Задание 2) Разработать блок схему алгоритма? для вычисления и вывода на экран суммы 5 случайных числе в диапазоне 0..36.

Задание: разработать программу вычисления выходного значения функ-ции y=f(x1,x2,x3,x4). Тип входных и выходных данных, вид функции заданы в табл. 2.

Выходное значение и входные должны отображаться на экране в виде: X1= X2= X3= X4= Y=

Разработать функцию, которая автоматически заполняет массив из 10 наборов входных данных. Массив затем подвергается обработке, т.е. в цикле вычисляются значения функции и выводятся на экран в виде: Y1= Y2= Y3= Y4= , и т.д.

тип входных данных: целое тип выходных данных: целое, функция: x1*sin(x2) + x3*sin(x4)

ЛБ- 70 Разработайте алгоритм для вычисления площади треугольника: s = 1/2ah, где а – длина основания треугольника, h – его высота.

ВБ- 71 Разработайте схему алгоритма, который проверяет, не превосходит ли сумма двух действительных чисел А и В числа 100. Если не превосходит, установить значение флага F=0, иначе установить значение флага F=1. Вывести значение F.

ЦА-10 Разработайте схему алгоритма для вычисления суммы S первых n целых чисел. Предусмотрите ввод значения n с клавиатуры. Текущее значение целого числа имеет имя i (i = 1, 2, .., n).

Помогите решить задачуна паскале.

Возможность отправлять закодированные сообщения во время Второй мировой войны была достаточно важной для союзников. Сообщения всегда отправлялись после их кодирования при помощи известного пароля. Иметь фиксированный пароль было небезопасно, поэтому возникла необходимость часто изменять его. Однако следовало разработать механизм отправления нового пароля. У одного из математиков, работавших в криптографической команде, возникла умная идея - отправить пароль, скрытый в самом сообщении. Интересным моментом было то, что получателю сообщения достаточно было знать только размер пароля, а потом найти его в полученном тексте.

Пароль размера n можно найти поиском в тексте наиболее часто встречаемой подстроки из n символов. После нахождения пароля все подстроки совпадающие с ним, удаляются из текста. Теперь пароль можно использовать для расшифровки сообщения.

Однако Ваша задача будет упрощена. Вам достаточно написать программу, которая по заданному размеру пароля и закодированному сообщению найдет пароль в соответствии с описанным выше алгоритмом.

Рассмотрим пример, в котором размер пароля равен трем (n = 3), а текст сообщения имеет вид baababacb. Паролем будет aba, потому что размер этой подстроки 3, она появляется чаще всего во всем тексте (дважды), а остальные шесть различных подстрок появляются только один раз (baa, aab, bab, bac, acb).

Технические условия

Входные данные

Состоит из нескольких тестов. Каждый тест представляет собой одну строку, в которой находится длина пароля n (0 < n ≤ 10) и закодированное сообщение. Сообщение содержит только прописные буквы латинского алфавита, его длина не более 106 и не меньше n.

Выходные данные

Для каждого теста в отдельной строке следует вывести искомый пароль. Если существует несколько паролей, удовлетворяющих задаче, то вывести лексикографически наименьший.



Вы находитесь на странице вопроса "Разработайте", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.