Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Решить в Pascal. Перед тем как написать ответ, проверить решение.

10-11 класс

Makonya99 24 февр. 2014 г., 11:39:40 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Zukrynka
24 февр. 2014 г., 12:51:19 (10 лет назад)

Program zadacha1;
Var matrica: array[1..100, 1..100] of integer;
i, j, N, M : integer;
Begin
Randomize;
Write('Vv N ');
Readln(N);
Write('Vv M ');
Readln(M);
For i:=1 to N do      {zapolnenije matrici}
For j:=1 to M do 
Begin 
matrica[i,j]:=random(50); 
End;
For i:=1 to N do      {vivod ee na ekran} 
Begin 
For j:=1 to M do 
Begin 
Write(matrica[i,j]:5); 
End; 
Writeln; 
end;
Writeln('Preobrazovannaja matrica ');
For i:=1 to N do         {preobrazovatelnije dejstvia} 
Begin 
For j:=1 to M do 
Begin 
If j<=M div 2 then   
Begin   
matrica[i,M-j+1]:=matrica[i,j];   
End; 
Write(matrica[i,j]:5);  {vivod polychennoj matrici na ekran. ':5' dlya togo, chtobi elementy ne slipalis} 
end; 
Writeln; 
end;
end.

Ответить

Другие вопросы из категории

1. Дано n чисел. Найти колличество тех, которые делятся на 5, и не делятся на 7.

2. Найти квадраты всех отрицательных чисел среди N заданных.
3. Найти количество чисел, среди N введенных,которые имеют нечетные порядковые номера, а сами являются четными числам.
4. напишите программу для вычисления суммы:
- 1*1!+2*2!+3*3!+....+n*n!
- 1*3+3*5+5*7+...n(n+2)
- 1+11+111+...+111+1-n слагаемых.
Помогите, пожалуйста написать программы для паскаля, очень нужно. Заранее спасибо.

Для кодирования букв О, Л, А, З, К используются двоичные коды чисел 0, 1, 2, 3 и 4 соответственно (с сохранением одного незначащего нуля в случае

одноразрядного представления). Если таким способом закодировать последовательность символов ЗАКОЛКА и записать результат в шестнадцатеричном коде, то получится:
1) 4531253 2) 9876 3) E832 4) 238E
----------------------------
Помогите,пожалуйста! Желательно с кратким решением,потому что самой понять тоже хочется)

Читайте также

Дан двумерный массив m*n , заполните его числами, найти наибольший элемент в каждой строке, вывести его значения и координаты.

Решить в Pascal. Перед тем как выкладывать ответ, проверьте решение.

ПОМОГИИИИТЕЕЕЕ!!!!!!!ОООЧЕНЬ СРООЧНОО!!! Тема Компьютерное моделирование. Предложите этапы построения компьютерной модели для решения одной из следующих

задач.Задача решается в Pascal ABC 1.В искусственный водоём запустили 100000 рыб. Ежегодно из водоёма забирают 12% рыб.Естественный прирост составляет 20%.Какое кол-во рыб будет в водоёме через 8 лет??

ПОЖАЛУЙСТА! СРОЧНО!

У Толи есть доступ к сети Интернет по высокоскоростному одностороннему радиоканалу,обеспечивающему скорость получения информации 220 бит в секунду. У Миши нет скоростного доступа вИнтернет, но есть возможность получать информацию от Толи по низкоскоростному телефонному каналусо средней скоростью 213 бит в секунду. Миша договорился с Толей, что тот будет скачивать для негоданные объемом 10 Мбайт по высокоскоростному каналу и ретранслировать их Мише понизкоскоростному каналу. Компьютер Толи может начать ретрансляцию данных не раньше, чем им будутполучены первые 1024 Кбайт этих данных. Каков минимально возможный промежуток времени (всекундах) с момента начала скачивания Толей данных до полного их получения Мишей? В ответе укажитетолько число, слово «секунд» или букву «с» добавлять не нужно

2
Документ обьемом 10мбайт можно передать с одного компьютера на другой 2 способами а-сжать архиватором по каналу связи и распаковать
б-передать по каналу связи без использования архиватора
какой способ быстрее если
-средняя скорость передачи данных составляет 2^18бит в секунду
-объем сжатого архиватором документа равен 30% от исходного
-время требуемое на сжатие документа 7 секунд , на распаковку 1 секунда?
в ответе указать решение и на сколько их разница в секундах будет больше.



Вы находитесь на странице вопроса "Решить в Pascal. Перед тем как написать ответ, проверить решение.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.