Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

ПАСКАЛЬ! ПОМОГИТЕ, СРОЧНО!

5-9 класс

Задать случайным образом 9 элементов числового массива – дробные числа от 10 до 50. В этом массиве:
1. Найти минимальный элемент и увеличить его на 100.
2. Найти максимальный элемент и поменять его местами с первым элементом.
3. Найти минимальный и максимальный элемент в числовом массиве из 10 элементов, заданных с клавиатуры. Поменять их местами.

Olga9627 22 мая 2014 г., 14:31:47 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Murat33
22 мая 2014 г., 16:45:02 (9 лет назад)

1,2 задание

var
a:array [1..9] of real;
i,k:integer;
j:real;
begin
randomize;
writeln('Массив:');
for i:=1 to 9 do
begin
a[i]:=(random(410)+100)/10;
write(a[i],' ');
end;
writeln;
writeln('Массив после увелечения минимального элемента на 100:');
k:=1;
for i:=2 to 9 do
if a[i]<a[k] then k:=i;
a[k]:=a[k]+100;
for i:=1 to 9 do
write(a[i],' ');
writeln;
writeln('Массив после престановки максиального элемента с первым:');
j:=a[1];
a[1]:=a[k];
a[k]:=j;
for i:=1 to 9 do
write(a[i],' ');
writeln;
end.

3 задание
var
a:array [1..10] of integer;
i,mn,mx:integer;
begin
writeln('Введите массив:');
for i:=1 to 10 do
readln(a[i]);
mn:=1; mx:=1;
writeln('Массив');
for i:=1 to 10 do
begin
if a[i]<a[mn] then mn:=i;
if a[i]>a[mx] then mx:=i;
write(a[i],' ');
end;
i:=a[mx];
a[mx]:=a[mn];
a[mn]:=i;
writeln;
writeln('Массив после престановки:');
for i:=1 to 10 do
write(a[i],' ');
writeln;
end.

Ответить

Другие вопросы из категории

Объясните смысл следующих записей на языке HTML:

<area shape=rect coords="33, 60, 191, 246" href="algoritm1.htm">
<area shape=poly coords="534, 62, 699, 62, 698, 236, 626, 261, 534,235"href="algoritm1.htm">
<area shape=circle cords="366, 147, 109" href="algoritm1.htm">

Помогите, пожалуйста!

Средняя скорость чтения для учащихся 9-11 классов составляет 160 слов в минуту. Подсчитайте, какое количество информации они перерабатывают за 5 часов непрерывного чтения, если средняя длина слова равна 10 буквам.
Заранее спасибо.

Здравствуйте!

Информатика 9 класс.
задание.
Составьте программу, которая заполняет массив А[1..10] СЛУЧАЙНЫМИ ЦЕЛЫМИ числами в диапазоне от 1 до 10 и находит количество элементов, КОТОРЫЕ БОЛЬШЕ СВОЕГО СОСЕДА СПРАВА.

пример вывода:
Исходный массив:
10 2 4 1 3 5 7 8 2 7
Количество элементов, которые больше своего соседа справа=3
БУДУ ОЧЕНЬ БЛАГОДАРНА

Читайте также

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Даны натуральное число n и вещественные числа a1, a2, ..., an. Определить среднее арифметическое вещественных чисел...

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

В небоскрёбе n этажей и 1 подъезд,на каждом этаже по 3 квартиры,лифт останавливается только на не чётных этажах .Человек садится в лифт и нажимает номер

нужной ему квартиры.На какой этаж дома довезёт лифт человека.
(в паскале) плиззз помогите срочно надо

Пожалуйста помогите срочно. Напишите программу в паскале для 9класса отображающую третий закон Ньютона. Если не можете сюда кинуть, киньте на мой мейл -

[email protected] заранее спасибо



Вы находитесь на странице вопроса "ПАСКАЛЬ! ПОМОГИТЕ, СРОЧНО!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.