Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите пожалуйста сделать программу на С++.

5-9 класс

Даны отрезки a,b,c,d. Для каждой тройки этих отрезков, из которых можно построить треугольник, найти площадь данного треугольника. использовать функцию определения площади треугольника по длинам его сторон.

ГитараДжа 20 июля 2014 г., 4:54:02 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Zaharra
20 июля 2014 г., 5:43:57 (9 лет назад)

#include <iostream>

using namespace std;


void TriangleArea(double a, double b, double c)
{
  double p = (a + b + c) / 2;

+ 0 -
Lexaqn5555
20 июля 2014 г., 6:52:23 (9 лет назад)

Добрый день! К сожалению я не работаю с C++, но если это поможет, то вот эта задача в Pascal
VAR a,b,c,d:REAL;
PROCEDURE Print_S(x,y,z:REAL);
 VAR  p,S:REAL;
 begin  If ((x+y)>z) and ((x+z)>y) and ((y+z)>x) then 
 begin   
p:=x+y+z;
S:=SQRT(p*(p-x)*(p-y)*(p-z));
WriteLn('S= ',S);
end
 else
Writeln('Треугольник не существует!');
end;
BEGIN Write('a= ');
ReadLn(a);
 Write('b= ');
 ReadLn(b);
 Write('c= ');
 ReadLn(c);
 Write('d= ');
 ReadLn(d);
 WriteLn;
 WriteLn('Стороны ',a,'; ',b,'; ',c);
 Print_S(a,b,c);
 WriteLn;
 WriteLn('Стороны ',a,'; ',b,'; ',d);
 Print_S(a,b,d);
 WriteLn;
 WriteLn('Стороны ',a,'; ',c,'; ',d); 
Print_S(a,c,d);
 WriteLn;
 WriteLn('Стороны ',b,'; ',c,'; ',d);
 Print_S(b,c,d);
END.

+ 0 -
Geragera
20 июля 2014 г., 9:50:06 (9 лет назад)

хорошо, сделаю

Ответить

Другие вопросы из категории

1.Сколько двоек содержит десятичное число 89,

записанное в системе счисления с основанием 3.
2.Запишите десятичное число 63 в системе
счисления с основанием 7.
3.Определить старшую цифру системы счисления с
основанием 20.
4.Вычислить 1DA15 + 4349 ->9
5.Какому десятичному числу соответствует число 12228221111112223 Помогите пожалуйста с этими заданиями, если сможете то срочно надо))

Переведите в Мбайты 224 байт

Читайте также

Помогите,пожалуйста,написать программу по информатике.Вот такое условие:

Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет:
1). сумму чисел, не превышающих 10;
2). сумму чисел,кратных 3. Помогите пожалуйста,написать эту программу на PaskalABC.

ПОМОГИТЕ ПОЖАЛУЙСТА СРОЧНО

Найдите произведение цифр заданного четырехзначного числа...Сделать программу на Паскаль

Помогите, пожалуйста, написать программу на Паскале.

Дана строка. Верно ли, что второе слово начинается на ту же букву, которой заканчивается третье слово?

Помогите пожалуйста сделать задачу на программе Pascal.

Найти максимальное число между двумя числами a и b



Вы находитесь на странице вопроса "Помогите пожалуйста сделать программу на С++.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.