Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Решите пожалуйста.(в паскале или

5-9 класс

конструкторе) Получить массив из n случайность лежащих в интервале от -50 до 100, определить каких чисел в нем больше четных положительных или нечетных отрицательных?

Angelina6699 15 апр. 2014 г., 1:01:24 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Emailmadambe
15 апр. 2014 г., 3:57:20 (10 лет назад)

var
 i,n,sum1,sum2:integer;
 mas:array[1..999] of integer;

begin
 sum1:=0;//Нечет. Отриц.
 sum2:=0; //Чет. Положит.
randomize;
 readln(n);
 for i:=1 to n do
  mas[i]:=random(151)-50;
 for i:=1 to n do
  if (mas[i]>0) AND (mas[i] mod 2 = 0) then
   sum2:=sum2+1
  else
   if (mas[i]<0) AND (mas[i] mod 2 <> 0) then
    sum1:=sum1+1;
 if sum1=sum2 then
  writeln('Поровну');
 if sum1>sum2 then
  writeln('Больше нечетных отрицательных');
 if sum1<sum2 then
  writeln('Больше четных положительных');
end.

Ответить

Другие вопросы из категории

1. Запишите в традиционной математической форме (при записи нельзя использовать трех- и четырехэтажные дроби) : а) C2/(A5+3) б) A1*A2/(D12/D2*D3) в)

F4^3*A4 .


1. Придумайте и сформулируйте условие задачи, для решения которой можно использовать следующую ЭТ

A B
1 15 =A1/A4*100
2 30 =A2/A4*100
3 10 =A3/A4*100
4 =A1+A2+A3


Составить программу, решающую следующую задачу: Клиент внес

в банк R рублей.
Каждый месяц эта сумма увеличивается на W рублей. Сколько будет у клиента денег через три
месяца?

помогите пожалуйста

что больше
1.5кБ или 1536Б
2 в 11 степени или 255Б

Читайте также

Решите, пожалуйста, в паскале)
1)поменять местами первую и последнюю цифру 3-х значного числа (через div и mod) командами пжл

2)Скорость лодки в стоячей воде V км/ч Скорость течения реки U км/ч (U 3) стоимость погонного метра шелка стоит х-золотых. сколько заплатит Грей за ткань своей бригантины, если общая площадь S парусов-(свое число),а ширина ткани в рулоне L-см.
РЕШИТЕ ПОЖАЛУЙСТА В ПАСКАЛЕ!!!!!
ЧЕРЕЗ VAR, присвоить, writeln,readln

Решите, пожалуйста, в паскале)


Вы находитесь на странице вопроса "Решите пожалуйста.(в паскале или", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.