Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

написать программу на языке с#:Дана точка на плоскости с координатами (х, у). Составить программу,

10-11 класс

которая выдает одно из сообщений «Да», «Нет», «На границе» в зависимости от
того, лежит ли точка внутри заштрихованной области, вне заштрихованной области
или на ее границе.

Shexovzova21222 20 апр. 2013 г., 3:45:33 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Fhfgjdf
20 апр. 2013 г., 4:20:57 (11 лет назад)

using System;


namespace ConsoleApp {
    internal class Program {
        private static void Main() {
            Console.WriteLine("Введите x");
            var x = Convert.ToInt32(Console.ReadLine());
            Console.WriteLine("Введите y");
            var y = Convert.ToInt32(Console.ReadLine());

            if (Math.Abs(x) <= y && x * x + y * y <= 15 * 15) {
                if (Math.Abs(x) == y || x * x + y * y == 15 * 15) {
                    Console.WriteLine("На границе");
                }
                else {
                    Console.WriteLine("Да");
                }
            }
            else {
                Console.WriteLine("Нет");
            }

            Console.ReadKey();
        }
    }
}

Ответить

Другие вопросы из категории

паскаль

Найти все натуральные
решения уравнения:x^3+y^3=M . Где М>0 задает
пользователь. Использовать вложенные циклы.

Читайте также

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

1) Напишите пожалуйста программу (на языке BASIC) вычисления по длинам двух сторон треугольника и углу между ними длины третьей стороны и двух других

углов.
2)
Напишите пожалуйста программу (на языке BASIC) для определения подобия:
а) двух прямоугольников по двум смежным сторонам;
б) двух треугольников по трем сторонам.

ДАМ 22 ПУНКТА СРОЧНО

СОСТАВИТЬ ПРОГРАММУ НА ЯЗЫКЕ ПАСКАЛЬ
данны два числа a и b.составить программу для вычисления среднего арифметического кубоы этих чисел

программа на C++ в визуальном режиме (есть несколько вариантов кода программы)

доброй ночи, уважаемые программисты и успевающие в учебе студенты. помогите, пожалуйста, написать программу на C++ (в визуальной вкладке).

ВОТ ЗАДАНИЕ:
дано три переменные вещественного типа. если их значения упорядочены по возрастанию или убыванию, то удвоить их; иначе заменить значение каждой переменной на противоположное. вывести значения переменных.


я прикрепила несколько тестовых файлов (блокнот) в которых есть несколько вариантов решение этого задание (то есть коды программ), а вы скажите какой из них лучше всего подходит, а также скажите какие компоненты нужно кинуть на форму-дизайн (то есть какие кнопки, и что на них писать). в этих 3 файлов есть написанный код программы, нужно написать: на какие кнопки что писать и какой вариант решение больше подходит.

заранее огромное спасибо всем за помощь!!!

Написать программы на языке С++

1) С клавиатуры вводится 2 числа - целое и вещественное. Программа выводит их сумму на экран.
2) Написать процедуру, которая умножает число типа int на число типа float на число типа double и выводит результат на экран
3) Написать процедуру, которая будет выводить любой текст, являющийся ее аргументом
4) С клавиатуры вводится 5 символов поочередно, программа выводит на экран акроним к слову которая образует эти 5 символов



Вы находитесь на странице вопроса "написать программу на языке с#:Дана точка на плоскости с координатами (х, у). Составить программу,", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.