Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Среди трехзначных чисел найдите те ,сумма первой и последней цифр которого равна 7.

5-9 класс

Паскаль

кнопа27 04 сент. 2013 г., 11:41:18 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mari4653
04 сент. 2013 г., 12:31:18 (10 лет назад)

program z;
var n,a,b,s:integer;
begin
s:=0;
for n:=1 to 999 do
begin
a:=n mod 10;
b:=(n div 100) mod 10;
if a+b=7 then s:=s+1;
end;
writeln(s);
end.

Ответить

Другие вопросы из категории

1. Опишите,какие типы принтеров вы знаете? К каким типам устройств они относятся?

2. Какие типы анти вирусных программ вы знаете и какова должна быть профилактика заражения ПК от вирусов?
3. Графический интерфейс. Для чего служит графический интерфейс?
4. Координатные устройства ввода. Что к ним относится

Помогите решить 2 задачи

Читайте также

1)среди 15 чисел найдите сумму всех положительных чисел

2) среди 15 чисел найдите количество всех чисел которые являются не отрицательными

Напишите программу, которая сначала считывает целое положительное число, а затем печатает значение меньшей из его первой и последней цифр. Исходное число

не превышает 30 000. Программа должна напечатать только число, равное значению меньшей из его первой и последней цифр. Если число состоит из одной цифры, то минимальным является значение самой этой цифры.
Примеры работы программы:
Ввод: 3; Вывод:3
Ввод: 2194; Вывод: 2



Вы находитесь на странице вопроса "Среди трехзначных чисел найдите те ,сумма первой и последней цифр которого равна 7.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.