Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

даны 2 массива точек x(10) y(10). используя функцию вычислить точку со средними координатами. Basic.

10-11 класс

Sany1197 28 сент. 2013 г., 16:10:14 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Abdullaeva20001
28 сент. 2013 г., 17:44:10 (10 лет назад)

DIM A(10) AS INTEGER, B(10) AS INTEGER
DIM i AS INTEGER, s1 AS SINGLE, s2 AS SINGLE
PRINT "Введите иассив А(10)"
s1=0
FOR i=0 TO 9
    INPUT a(i)
    s1=s1+a(i)
NEXT i
PRINT "Введите иассив B(10)"
s2=0
FOR i=0 TO 9
    INPUT b(i)
    s2=s2+b(i)
NEXT i
s1=s1/10: s2=s2/10
PRINT "(";s1;",",s2)
END

Ответить

Другие вопросы из категории

Читайте также

СРОЧНО.Вот код.Это программа не вся ,здесь даны формулы для вычисления массивов, которые и нужно найти.Написал функцию, вроде бы всё нормально, но не могу

понять как присвоить вычисляемые значения массиву.Массивы Y(8), Z(10) , W(15) .Если что, то потом необходимо еще подсчитать общее количество в этих массивах.
program pr_10;
const b1 = 4;
b2 = 6;
c1 = 8;
c2 = 3;
d1 = 5;
d2 = 12;
var i,m:integer ; y,z,w:real;
function fY(i:integer):real;
begin
Y:=b1*sin(2*i)+exp((i-5)*ln(b2));
end;
function FZ(i:integer):real;
begin
Z:=c1*(i-4)+c2*sqr(sin(1.5*i));
end;
function FW(i:integer):real;
begin W:=d1*ln(0.1*i)+d2*exp((3)*ln(i-2.5));
end;
begin
for i:=1 to 8 do
begin

Ym[i]:= Y(i);
writeln('Y = ',y);
end;
end.

Напишите программу, которая вычисляет НОД двух чисел. Используйте функцию.

Напишите программу, которая вычисляет НОК двух чисел. Используйте функцию.

1.Дан целочисленный массив X(N). Найти сумму четных элементов массива .Если эта сумма больше заданного числа Z , то у элементов , расположенных на

нечетных местах , сменить знак на противоположный ,иначе выдать соответствующее сообщение.

2.Дан массив X(N,M) . Среди четных столбцов массива найти сумму положительных элементов

3.Найти произведение элементов каждого столбца массива принадлежащих промежутку [2,6] . Из полученных значений сформировать одномерный массив.

3. Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы вычисления а) y=x¹° б)y=x¹⁵ или а) y=x^10

б)y=x^15

Постараться использовать минимальное количество дополнительных переменных.

4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a,b,c. Схема циклического обмена: a ← b ← c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.



Вы находитесь на странице вопроса "даны 2 массива точек x(10) y(10). используя функцию вычислить точку со средними координатами. Basic.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.