Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дан текст, в котором есть цифры, найти сумму всех этих цифр

10-11 класс

Volmar 31 мая 2014 г., 5:45:57 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ostrinskaya201
31 мая 2014 г., 6:37:24 (9 лет назад)

Папа принес домой одного птенца. Лена насыпала ему 5 крошек. Но бедняга даже не посмотрел на еду. Девочка вынесла клетку на улицу и поставила у порога. Слетелись  10 воробьёв. Вдруг одна воробьиха взяла в клюв крошку и подлетела к птенцу.

+ 0 -
Polinakarmanova
31 мая 2014 г., 9:23:46 (9 лет назад)

var Digits:set of '0'..'9';
st:string;
i,s,t,t1:integer;
Begin
  read(st)
  for i := 1 to length(st) do begin
    if not (st[i] in Digits) then begin
      s:=s+t;
      t:=0;
    end
    else begin
      t1:=integer(st[i]);
      t:=t*10+t1;
    end;
  end;
  writeln('s=',s)
End.

 

на руби куда легчеst=gets.to_s
st=st.gsub(/\D+/,',')
a=(st.split(","))
s=0
a.each_index do |i|
    a[i]=a[i].to_i
    s+=a[i]
end
p a
p s

 

Ответить

Другие вопросы из категории

Читайте также

Дано натуральное число: определить а) количество цифр в нем б)сумму его цифр в)произведение его цифр г)среднее арифметическое его цифр

д)сумму квадратов его цифр е)сумму кубов его цифр ж)его первую цифру з)сумму его первой и последней цифр

Даны два целых числа А и В (А<В). Найти сумму всех целых чисел от А до В включительно Входные данные: ввести два целых числа А,В (1<=A,

B<=100).

Выходнфе данные: вывести сумму всех целых чисел от А до В включительно.

Можно, пожалуйста, с объяснением.

составить программу 1)найти сумму всех элементов массива (1до10) random. 2)сформировать массив из положительных и отрицательных элементов

от -10 до 30.найти кол-во положит и отриц элементов.найти сумму положит и произведение отриц.

Автомат получает на вход пятизначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам.1.Вычисляются два числа

- сумма первых трёх цифр и сумма последних трёх цифр.2.Полученные два числа записываются друг за другом в порядке не убывания (без разделителей).Пример.Исходное число:15177.Поразрядные суммы: 7 ,15.Результат: 715.Определите, сколько из приведенных ниже чисел могут получиться в результате работы автомата.2626 2618 2624 2628 2826 2426 1826 610.В ответ запишите только количество чисел ПОМОГИТЕ ПОЖАЛУЙСТА!!!!!!

Составить программы: 1.Дана строка символов, среди которых есть двоеточие. Определить, сколько символов следуют за двоеточием.

2.Дана строка символов, среди которых есть одна открывающаяся и одна закрывающаяся скобка. Подсчитать, сколько слов расположено внутри этих скобок.

3.Дана строка. Удалить из нее все запятые и подсчитать, сколько получилось удаленных символов.

Помогите, пожалуйста!



Вы находитесь на странице вопроса "Дан текст, в котором есть цифры, найти сумму всех этих цифр", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.