Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

количество значащих нулей в двоичной записи десятичного числа 129 равно

10-11 класс

5
6
7
8

Gordechina 07 июля 2014 г., 11:52:52 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
CarinaMaria
07 июля 2014 г., 13:21:49 (9 лет назад)

ровно 6 нулей не ьолее и не менее

Ответить

Другие вопросы из категории

написать программу на языке С#:. Последовательность

целых ненулевых чисел вводится с клавиатуры. Окончанием последовательность
является 0. Определите

произведение чисел, которые делятся на 5

Помогите составить программу

В зависимости от того введена ли открытая скобка или закрытая, напечатать "открытая круглая скобка" или "закрытая фигурная скобка".(учитывать круглые , квадратные,фигурные скобки)

Почему на этапе ввода последней ступени (т.е. задали х=5 и вводим 5 ступень) паскаль выкидывает ошибку: "Индекс находился вне границ массива", ведь al[x]

это его последний элемент, разве нет?
Код:

program s1;
var x, i:integer;
al, tl: array of real;
begin
writeln ('Введите количество ступеней ракеты'); read (x);
setlength (al, x);
setlength (tl, x);
for i:=1 to x do begin
writeln ('Введите ускорение ', i, ' ступени'); read (al[i]);
writeln ('Введите время работы ', i, ' ступени'); read (tl[i]);
end;
end.
P.S.: Переписать массив в статический не предлагать, нужен именно переменной длины. Заранее спасибо.

Читайте также

Помогите пожалуйста)

1) Количество единиц в двоичной записи десятичного числа 1023

2) количество значащих нулей в двоичной записи десятичного числа 501


1.Переведите числа 25, 31, 37, 63, 85, 127, 128 в двоичную систему счисления.

2. Переведите числа 1000112, 1011012, 1101112, 10010112, 10111112, 11010012 в десятичнуюсистему счисления.
3. Сколько единиц в двоичной записи чисел 173, 195, 126, 208?
4. Сколько значащих нулей в двоичной записи чисел 48, 73, 96, 254?
5. Как по записи числа в двоичной системе счисления определить, что оно – четное? делитсяна 4? на 8? на 32?
6. Выполните сложение в двоичной системе:а) 10101112 + 1101012б) 10101112 + 1101012в) 1011012 + 111112г) 101112 + 1011102д) 1110112 + 110112е) 1110112 + 100112Для проверки повторите вычисления, переходя к десятичной системе, а потом преобразуярезультат обратно в двоичную.
7. Выполните вычитание в двоичной системе:а) 1011012 – 111112б) 110112 – 1101012г) 1010112 – 110112д) 10112 – 1001012 в) 101112 – 1011102 е) 10012 – 1011012Для проверки повторите вычисления, переходя к десятичной системе, а потом преобразуярезультат обратно в двоичную.
8. Переведите в двоичную систему числа 13,125; 23,25; 37,375; 48,625; 78,875.
9. Переведите в двоичную систему числа 11,8; 15,3; 22,7, выделив период в дробной части.
10. Требуется проверить, верно ли, что среднее арифметическое 100 целых чисел превышает0,2. Как сделать это, не используя операции с дробными числами?



Вы находитесь на странице вопроса "количество значащих нулей в двоичной записи десятичного числа 129 равно", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.