Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Составьте программы "Угадай число от 1 до 10"

10-11 класс

И придумайте похожую задачу, только немного сложней. :)
Сорь за качество.

Dana0 26 февр. 2014 г., 13:18:12 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Irinaaaaa236
26 февр. 2014 г., 15:47:57 (10 лет назад)

числа загадываются от 1 до 10; с выходом и что делать вроде все понятно и так будет
uses crt;
var a,p,n,t:integer;
begin
clrscr;
p:=0;
repeat
a:=random(10);
 repeat 
 readln(n); 
 p:=p+1;
 if n=a then begin writeln('Вы угадали с ',p,' раза!'); p:=0; writeln('Поробуйте снова!'); readln; clrscr; end   
 else if n<a then writeln('Число введенное вами меньше загаданного,попробуйте снова')   
  else if n>a then writeln('Число введенное вами больше загаданного, попробуйте снова'); 
 until n=a;
writeln('Если хотите выйти введите "-1" ');
 readln(t);
  until t=-1;
 readln;
 end.  

Ответить

Другие вопросы из категории

Под алфавитом понимают:

1) -любую конечную последовательность символов;
2) -упорядоченный определенным образом конечный набор знаков, расположенных в строго определенной последовательности;
3) -совокупность знаков и символов;
4) -конечный набор любых знаков;
5) -произвольная последовательность конечного набора знаков или символов.

В чем проблема? Подскажите!

Читайте также

В программе используется одномерный целочисленный массив А с индексами от 0 до 10. Ниже представлен фрагмент программы в котором значения элементов

сначала задаются,а затем меняются.

Нц для i от 0 до 10

А [ i ] := i

кц

Нц для i от 0 до 4

С := A[ i ]

A[ i ] := A [10 - i ]

A [10 - i ] :=C

кц

Чему будут равны элементы массива после выполнения фрагмента программы?

1) 10 9 8 7 6 5 4 3 2 1 0

2) 0 1 2 3 4 5 6 7 8 9 10

3) 10 9 8 7 6 5 6 7 8 9 10

4) 0 1 2 3 4 5 4 3 2 1 0

Для кодирования номеров автомобилей принята следующая структура данных: Номер региона (двузначное число от 00 до 99), серия (комбинация из трех букв из

набора «А, В, Е, К, М, Н, О, Р, С, Т, У, Х»), номер (трехзначное число от 000 до 999). При создании базы данных автомобильных номеров Петя решил хранить каждый номер в виде массива из 8 символов (два символа на номер региона, три символа на серию и три символа на номер), кодируя каждый символ с помощью однобайтной кодировки ASCII. Вася решил уменьшить объем хранимых данных и принял решение хранить каждый номер в виде трех чисел – одно число для номера региона, одно число для серии (представив все возможные серии в виде натуральных чисел) и одно число для номера. Каждое число Вася будет хранить отдельно, используя для его кодирования минимально возможное число бит. На сколько бит уменьшится объем памяти, необходимый для хранения одного произвольного номера, в варианте кодирования Васи по сравнению с вариантом кодирования Пети? В ответе укажите целое число.

паскаль,1) вывести все четные числа от 1 до 15

2)вывести на экран числа от 2 до 9 с шагом 0,2

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.



Вы находитесь на странице вопроса "Составьте программы "Угадай число от 1 до 10"", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.