Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

дана строка. Каждую точку замените многоточием (т.е тремя точками). В чем беда? или совсем не правильно?

10-11 класс

var str : string;
q:integer;
k:string;
begin
writeln ('введите строку');
readln (str);k:='..';
q:=pos('.', str );
while q<>0 do
begin
insert (str,k, q );
q:=pos('.', str );
end;
writeln (str);
end.

AdeleLove0588 09 сент. 2013 г., 19:36:30 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
котейка4200
09 сент. 2013 г., 21:51:05 (10 лет назад)

var
  str: string;
  q: integer;
  k: string;

begin
  writeln('введите строку');
  readln(str);
  k := '..';
  q := pos('.', str );
  while q <> 0 do
  begin
    insert(k, str, q );
    q := PosEx('.', str, q + 3 );
  end;
  writeln(str);
end.

Ответить

Другие вопросы из категории

СРОЧНО, ПОЖАЛУЙСТА, НАПИШИТЕ КТО-НИБУДЬ, НА ЗАВТРА НАДО, УМОЛЯЮ, ТОЛЬКО ПРАВИЛЬНО!!!Я

УЖЕ 20 РАЗ ЭТО ЗАДАНИЕ ПОСЫЛАЮ, НАПИШИТЕ!!! КТО СМОЖЕТ, ТОЛЬКО ПРАВИЛЬНО!

У меня проблемы, не могу решить задачу. Дано предложение. Нужно его зашифровать следующим методом - 3 первых буквы с 3 последними буквами этого

предложения и т.д. Т.е. к примеру дано предложение "QQQWWWeeeTTTWWW" после зашифровки должно быть так "WWWTTTeeeWWWQQQ"

Читайте также

Составить программы: 1.Дана строка символов, среди которых есть двоеточие. Определить, сколько символов следуют за двоеточием.

2.Дана строка символов, среди которых есть одна открывающаяся и одна закрывающаяся скобка. Подсчитать, сколько слов расположено внутри этих скобок.

3.Дана строка. Удалить из нее все запятые и подсчитать, сколько получилось удаленных символов.

Помогите, пожалуйста!

Решите в паскале В данной строке каждый символ с номером,

кратным K, заменить на
пробел.

Дана строка , в которой содержится осмысленное текстовое сообщение. Слова сообщения разделяются В заданном формате дд- целое число из диапазона от 1 до

31, мм - целое число из диапазона от 1 до 12, а гг - целое число из диапазона от 1 до 2020 (если какая-то часть формата нарушена, то данная подстрока в качестве даты не рассматривается.) Заменить каждую дату сообщения на дату следующего дня. Написать программу на Паскале. Сроооооооооооооочнооо. Пооожалуйста.....

10-11 класс информатика ответов нет


Вы находитесь на странице вопроса "дана строка. Каждую точку замените многоточием (т.е тремя точками). В чем беда? или совсем не правильно?", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.