Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

4 Σ (S!+S) S=1 найдите ошибку, плиз program mar;

5-9 класс

uses crt;
var F,S:integer;
k:real;
begin
clrscr;
F:=1;
k:=0;
for S:=1 to 4 do
begin
F:=F*S;
k:=k*(F+S);
end;
writeln('k =',k:4:2);
readkey;
end.

маратик110398 28 сент. 2013 г., 8:55:15 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Holdon
28 сент. 2013 г., 11:47:29 (10 лет назад)

Вот так?

 

Program solution;
Uses Crt;
Var s : byte;
res, fact : word;

Begin
fact := 1;
res := 0;

For s := 1 to 4 do
        Begin
        res := res + s + fact;
        fact := fact * (s + 1);
        End;
Write(res);
ReadKey;
End.

Ответить

Другие вопросы из категории

Прошу, помогите пожалуйста:Завтра ужеПрошу, помогите пожалуйста:

Завтра уже надо сдавать.

Нельзя отнести к долговременным носителям информации:

а) дискету
б) молекулы ДНК
в) радиоволны
г) CD-ROM

Помогите,пожалуйста. Надобно написать программу в паскале.

Заполнить массив случайными числами в интервале от -10 до 10 и выполнить инверсию отдельно для 1 и 2 части.
Пример:
1 -2 6 -8 -3 | 5 -7 1 0 -4
-3 -8 6 -2 1 | -4 0 1 -7 5

Что делает в программе следующая строка?

For i:=l to 10 do read (M[i])
А) пересчет массива от 1 до 10
В)Заполнение массива
С)Ввод в массив десяти имен переменных
D) сортировка элементов массива

Читайте также

program mar; uses crt; var F,k:integer; S:real; begin clrscr; F:=1; S:=1; for k:=1 to 3 do

begin

F:=F*k;

S:=S*(2*F)/(k*k*k*k+k);

writeln('k = ',k );

readkey;

end.

Найдите ошибку, пожалуйста, программа не идет.

Прошу вас, помогите! Решается оценка!!! Найдите ошибки в программе 1)Program z1; var a:integer; begin a:=10; while

a<5 do

writeln(a);

a:=a+1;

End.

2)Program z2;

var a,s:integer;

begin

a:=1; s:=0;

while a<10 do begin

s:=s+a/2;

end;

writeln(s);

end.

Задача: Определить Сумму элементов матрицы кратных 3

Вот решение :
Program crh;
Const n=5; m=6;
Var a:array [1..N,1..M] of integer; i,s:integer;
Begin
For i:= 1 to N do
For k:= 1 to M do begin
write( 'Введите элемент массива');
Read(A[i,k]);
end;
For i:= 1 to N do
For k:= 1 to M do
if A mod 3 =0 then
s:=s+1;
write('Сумма элементов равна', s);
end.
Найдите ошибку, на строке if A mod 3 =0 then выдаёт ( операнды имеют неприводимые типы). Помогите сделать крч

Помгите пожалуйста! Найдите ошибки, а то он всякую чепуху считает.Заранее большое спасибо)))) Используя команду ветвления составить программу,

которая определяет, сколько чисел из К являются нечетными.

Program mass;

uses crt;

var i,k:integer;

a:array[1..100] of integer;

begin ClrScr;

k:=0;

randomize;

for i:=1 to 10 do begin

a[i]:=random(10)-5; write( a[i]:3);

if a[i] mod 2=1 then

k:=k+1;

end;

writeln ( 'Кол-во нечетных чисел из K ',k);

readln;

end.

Найдите ошибку

Program prim2;
Var x, y: real;
Begin
For x:=-10 to 10 do
Begin
y:-sqr (x);
Writeln ( x,' ', y)
end;
End.



Вы находитесь на странице вопроса "4 Σ (S!+S) S=1 найдите ошибку, плиз program mar;", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.