Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Написать программу нахождения сопротивления цепи из n резисторов (r1,r2, ..rn) соединённых последовательно (PascalABC)

5-9 класс

Allonim17 26 июня 2014 г., 11:50:47 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
самара4ка
26 июня 2014 г., 12:39:10 (9 лет назад)

При последовательном соединении сопротивление цепи будет равно сумме сопротивлений.
uses crt;
var r:array [1..10000] of integer;
    n,x,RSum:integer;
begin
     RSum:=0;
     write('N='); readln(N);
     for x:=1 to N do
     begin
          write('R',x,'=');
          readln(r[x]);
          RSum:=RSum+r[x];
     end;
     writeln('R=',RSum);
end.     

+ 0 -
Fliisa
26 июня 2014 г., 14:50:26 (9 лет назад)

var a, n, i, s : integer;
begin
read (n);
for i:=1 to n do 
 begin
 read (a);
 s:=s+a;
 end;
write (s);
end.

В последовательном соединении R_c=R_1+R_2+R_3+...+R_n

P.S. Надеюсь на благодарность и лучший ответ.

Ответить

Другие вопросы из категории

выделите попарно общие и единичные понятия и запишите их в соответствующие столбцы таблицы понятия композитор Пушкин художник Чайковский озеро горы Репин

поэт Байкал Париж Карпаты филосф город Сократ полководец Чита Суворов учёный река Ньютон Лена город

Читайте также

Паскаль ABC 1.Написать программу рисующую вертикальную цепочку из 7 кругов 2.Написать программу рисующую цепочку из 5 кругов

расположденных по диагонали

3.Написать программу рисующую горизонтальную цепочку из 12 кругов,каждый круг должен на половину закрывать предыдущий

Помогите,а то сижу с паскалем уже час с лишним и все никак не получается..

Заранее спасибо)

Помогите написать программу для Паскаля.

1. Написать программу нахождения произведения n чисел.

1. Даны два различных вещественных числа X и Y. Написать программу, возведения наименьшего из чисел в квадрат, наибольшего – в куб и нахождения среднего

арифметического полученных значений.
2. За весну Обломов похудел на p1 кг, за лето поправился на p2 кг, за осень похудел на p3 кг, за зиму поправился на p4 кг. Написать программу, определяющую, похудел или поправился за год Обломов.
3. Написать программу, которая определяет, является ли целое число четным двузначным числом.
4. Даны коэффициенты квадратного уравнения. Написать программу, определяющую его корни

помогите пожалуйста..очень надо....что нибудь из этих задач..1)написать программу которая поменяет местами первую и последнюю букву в слове. 2)написать

программу которая вставит между буквами веденного слова пробелы 3)написать программу вывода на экран деление двух чисел

5-9 класс информатика ответов нет


Вы находитесь на странице вопроса "Написать программу нахождения сопротивления цепи из n резисторов (r1,r2, ..rn) соединённых последовательно (PascalABC)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.