Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Найдите все трехзначные числа, сумма цифр которых кратна 7 и сами числа также делятся на 7.

10-11 класс

Nastygan2010 07 янв. 2017 г., 9:30:48 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
КамиСаби
07 янв. 2017 г., 11:19:13 (7 лет назад)

могу подсказать кратные 7
число n mod 7=0 

+ 0 -
Reuzhana
07 янв. 2017 г., 13:04:31 (7 лет назад)


var a,b,c,d,e,f:integer;
begin
for a:=100 to 999 do begin
b:=a div 100;
c:=a mod 10;
d:=a mod 100;
e:=d div 10;
f:=c+b+e;
if (f mod 7=0) and (a mod 7=0) then
writeln(a,' ');
end;
end.

Ответить

Другие вопросы из категории

составьте программу исследования положительного вещественного числа А, в которой определились бы значения следующих величин: целая часть, дробная

часть, значения арифметического квадратного корня, остаток от деления на 5, символ по целой части числа.

как написать эту процедуру в С++ ? Program pr;

uses crt;

type mas=array[1..10] of integer;

Var a,b:mas;

procedure Vvod(Var a:mas);
Var i:integer;
Begin
for i:=1 to 10 do readln(a[i]);
end;

3. Мальчик решил почистить аквариум. Начал с переселения рыб в банку. Семейство рыб, проживающих в аквариуме, составляло 40 штук. Первую рыбку он поймал

быстро, затратив 5 с, и еще 2 с потратил на перекладывание в банку. Но чем меньше становилось в воде рыбок, тем труднее было их поймать. На каждую следующую рыбу он затрачивал больше на 5%, чем на предыдущую. Сколько минут времени он затратит на переселение рыбок? Построить и исследовать модель в Ms Excel.

Читайте также

Найдите все трехзначные числа, сумма цифр которых кратна 7

и сами числа также делятся на 7.

Язык "Паскаль АВС" 1.Среди двухзначных чисел найти количество четных чисел. 2. Среди двухзначных чисел найдите те числа, у которых первая цифра четная.

3. Среди двухзначных чисел найдите те числа, которые кратны 3 и 4. 4. Среди трехзначных чисел найдите те, у которых все цифры равны. 5. Найдите среди трехзначных чисел симметричные числа. 6. Найдите среди четырехзначных чисел симметричные числа. 7. Найдите все трехзначные числа такие, что сумма цифр равна А, а само число делится на В. А и В вводятся с клавиатуры. 8. Найдите все трехзначные числа такие, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, при увеличении на 4 делятся на 5. 9. Найдите количество трехзначных чисел, сумма цифр которых равна А, а само число заканчивается на В, А и В вводятся с клавиатуры. 10. Найдите все трехзначные числа, у которых сумма крайних цифр равна сумме средних цифр, а само число делится на 6 и 27. 11.Найдите все трехзначные числа, которые при делении на 2 дают остаток 1, при делении на 3-остаток 2, при делении на 4-остаток 3, само число делится на5. 12. Найдите все четырехзначные числа, в которых есть две одинаковые цифры. 13. Найдите сумму всех чисел из промежутка от А до В, кратных 13 и 5, А и В вводятся с клавиатуры. 14. Найдите все симметричные четырехзначные числа. 15.Найдите все трехзначные числа, которые состоят из различных цифр, а их сумма равна А.

Программу на Си. Найти

все трехзначные числа, сумма цифр которых равна данному целому числу.

Сумма цифр. Даны два числа А и В. Подсчитайте кол-во натуральных чисел на отрезке от А до В , сумма цифр которых четна. Программа

получает на вход два натуральных числа А и В, не превосходящих 10^9^ А<=В . Программа должна вывести одно число - кол-во натуральных чисел, больше или равных А и меньших или равных В, сумма цифр которых четна.



Вы находитесь на странице вопроса "Найдите все трехзначные числа, сумма цифр которых кратна 7 и сами числа также делятся на 7.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.