Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Написать программу в Паскале. Подсчитать сумму четных целых чисел находящихся от одного до значения введенного пользователем

10-11 класс

Shadymurder 01 мая 2014 г., 2:28:52 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dratskaya98ksushaOK
01 мая 2014 г., 3:39:01 (10 лет назад)

program summa;
   uses crt;
      var a, s, m, i:integer;
begin
clrscr;
   read(i);
s:=0;
  while i<>0 do begin
m:=a mod 10;
s:=s+m;
a:=a mod 10;
a:=i+s;  end;
   write('s=',s);
 end.

Ответить

Другие вопросы из категории

Ребят, помогите решить Пр-2

информация на фото, заранее спасибо)

Распишите до мелочей пожалуйста
Помогите, пожалуйста(Паскаль):

Даны действительные положительные числа x

Читайте также

Даны два целых числа А и В (А<В). Найти сумму всех целых чисел от А до В включительно Входные данные: ввести два целых числа А,В (1<=A,

B<=100).

Выходнфе данные: вывести сумму всех целых чисел от А до В включительно.

Можно, пожалуйста, с объяснением.

Дана строка , в которой содержится осмысленное текстовое сообщение. Слова сообщения разделяются В заданном формате дд- целое число из диапазона от 1 до

31, мм - целое число из диапазона от 1 до 12, а гг - целое число из диапазона от 1 до 2020 (если какая-то часть формата нарушена, то данная подстрока в качестве даты не рассматривается.) Заменить каждую дату сообщения на дату следующего дня. Написать программу на Паскале. Сроооооооооооооочнооо. Пооожалуйста.....

10-11 класс информатика ответов нет
Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала коо

рдинат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу



Вы находитесь на странице вопроса "Написать программу в Паскале. Подсчитать сумму четных целых чисел находящихся от одного до значения введенного пользователем", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.