Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Составить алгоритм , с помощью которого определить сумму всех членов трехзначных чисел.

10-11 класс

Juliaaa22 20 июня 2014 г., 6:20:34 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
тенна
20 июня 2014 г., 7:47:50 (9 лет назад)

вот решение на с/с++ :

#include <iostream>

using namespace std;
int main()
{
int num; // обьявляем переменную под нужное число
cin>>num; //считываем данное число.
int sum=0; // в этой переменной будем записывать сумму чисел.
while(num!=0)
{
sum+=num%10;
num=(num-num%10)/10;
}
cout<<sum; // вывод результата.
return 0;
}

Ответить

Другие вопросы из категории

Написать алгоритм вычисления по формуле:

y=(1-x^2+2,5x^3+x^4)^2

Читайте также

1) Составить функцию, которая определяет наибольшее из трех чисел и привести пример ее использования. Пример: Введите три числа:

28 15 10

Наибольшее число: 28

2)Составить функцию, которая определяет сумму всех чисел от 1 до N и привести пример ее использования.

Пример:

Введите число:

100

Сумма = 500

Буду очень признателен за помощь.

помогите решить задачки по Паскалю "4": Составить функцию, которая определяет сумму всех чисел от 1 до N и привести пример ее

использования. Пример: Введите число: 100 сумма = 5050

"5":

Составить функцию, которая определяет, сколько зерен попросил положить на N-ую клетку изобретатель шахмат (на 1-ую – 1 зерно, на 2-ую – 2 зерна, на 3-ю – 4 зерна, …) Пример: Введите номер клетки: 28 На 28-ой клетке 134217728 зерен.

В редакции газеты имеется 14 внештатных корреспондентов, каждому из которых присвоили порядковый номер (от одного до 14 включительно). Известно, сколько

статей опубликовал каждый внештатный корреспондент. Составьте программу, с помощью которой определить, сколько денег нужно выплатить каждому внештатному корреспонденту, если за каждую опубликованную статью полагается по 50 у.е. Вознаграждения.



Вы находитесь на странице вопроса "Составить алгоритм , с помощью которого определить сумму всех членов трехзначных чисел.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.