Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Для матрицы A(n×n) определить разность между максимальными элементами верхней и нижней треугольных матриц

10-11 класс

Паскаль,помогите пожалуйста,уже час раздумываю над программой

Hgfhytgdh34 06 авг. 2014 г., 16:36:09 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vadiktubay
06 авг. 2014 г., 17:55:00 (9 лет назад)

const
  n = 8;

var
  i, j, umax, lmax: integer;
  a: array[1..n, 1..n] of integer;

begin
  Randomize;
  writeln('Исходный массив');
  for i := 1 to n do
  begin
    for j := 1 to n do
    begin
      a[i, j] := Random(40) - 20;
      write(a[i, j]:4)
    end;
    writeln;
  end;
  umax := -100;
  for i := 1 to n do
    for j := i to n do
      if umax < a[i, j] then umax := a[i, j];
  lmax := -100;
  for i := 1 to n do
    for j := 1 to i do
      if lmax < a[i, j] then lmax := a[i, j];
  writeln('Разность максимумов равна ', umax - lmax)
end.

Тестовое решение:

Исходный массив
  -5  18 -13   1 -16   5   0 -13
   4 -18 -17 -14   2  10  -2 -15
 -15  -8  -6 -16 -10 -12 -18 -17
 -18   6  11  -5   4  -6  -1   1
  10  14   3  -7   2  11  10  -1
   6  -2 -20   1   4   9  13  -4
  -9  -7   4  -6 -12   3   1 -14
  15 -16  -1  -3  13 -15   3 -10
Разность максимумов равна 3


+ 0 -
Айза222
06 авг. 2014 г., 18:57:23 (9 лет назад)

Скажите, как выглядят нижняя и верхняя треугольные матрицы. Тогда, наверное, помогу

+ 0 -
Zadan4ik
06 авг. 2014 г., 20:04:23 (9 лет назад)

ну треугольная матрица это вроде как половина квадратной матрицы,под которой остальные числа равны нулю,но второй аргумент здесь наверное можно не учитывать

Ответить

Читайте также

Помогите с задачкой на паскале

Сформировать целочисленный массив из 15 элементов. Элементы массива ввести как случайные числа в диапазоне от –8 до 10. Отсортировать массив по возрастанию методом выбора и найти наибольшее значение разности между соседними элементами.

Помогите пожалуйста!

дан массив B из K элементов. Определить будет ли максимальный элемент чётным.

Ребятушки помогите пожалуйста по програмированию)) в паскале

Написать программу, выполняющую поиск максимальных элементов в каждой строке заданной матрицы.

Ребятушки помогите пожалуйста по програмированию))0

Написать программу, выполняющую поиск максимальных элементов в каждой строке заданной матрицы.



Вы находитесь на странице вопроса "Для матрицы A(n×n) определить разность между максимальными элементами верхней и нижней треугольных матриц", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.