Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

написать программу,которая вычисляет сумму первых четных целых n положительных чисел,количество суммированных чисел должно вводиться во время работы

5-9 класс

программы.

ЛуизочкаКО 24 марта 2015 г., 13:51:20 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sesemionova201
24 марта 2015 г., 16:22:01 (9 лет назад)

#include <iostream>

int main()
{
    int n;
    std::cin >> n;
    int sum = 0,k = 0;
    for (int i=1; i<=n; i++)
    {
        sum+=k;
        k+=2;
    }
    std::cout <<"Summa: " <<sum <<std::endl;
    return 0;
}

+ 0 -
Zhbanko
24 марта 2015 г., 18:07:46 (9 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

Определить, счастливый ли билетик.

С помощью 2 массивов. Принцип такой: на билете 6 цифр. Если сумма первых трех будет равна сумме следующих трех, то билет-счастливый.

1.А&(BvA)

2.(AиВ) или не А

Читайте также

Ребята,помогите пожалуйста!!!))) суть задания: Составьте блок-схему и программу на языке VBA, которая вычисляет сумму первых n целых положительных четных

чисел. Количество суммируемых
чисел должно вводиться во время работы программы. Программа должна
проверять правильность введенных пользователем данных и, если они неверные ( n ≤ 0 ), выдавать сообщение об ошибке.
Буду очень признательна, если кто-нибудь возьмется за это задание. Спасибо)

Написать программу,которая вычисляет сумму первых n членов ряда 1,3,5,7. Количество суммируемых членов ряда задаётся во время роботы программы.

(ниже представлен рекомендуемый вид экрана во время работы программы)
Вычисление частичной суммы рада 1,3,5,7.
Введите количество суммируемых членов ряда: 15
Сумма первых 15 членов ряда равна 330.



Вы находитесь на странице вопроса "написать программу,которая вычисляет сумму первых четных целых n положительных чисел,количество суммированных чисел должно вводиться во время работы", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.