Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

С клавиатуры вводится целое число, содержащие не более 7 цифр. Определить максимальную цифру в этом числе.

5-9 класс

Программа Паскаль. Цикл с пред условием

Chishevoivlad 21 окт. 2014 г., 16:43:40 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Дима2313123
21 окт. 2014 г., 18:46:37 (9 лет назад)

program maxx;
var max,n,k,i:integer;
begin
writeln('введите кол-во чисел');
readln(k);
max:=0;
for i:=1 to k do
begin
readln(n);
if n>max then max:=n;
end;
writeln(max);
end.

Ответить

Другие вопросы из категории

Метеорологическая станция ведет наблюдение за температурой воздуха

Считается, что температура должна быть представлена целым числом. При этом она не может опускаться ниже минус 14 градусов и подниматься выше плюс 18 градусов. Каждое значение температуры записывается при помощи минимально возможного количества бит.За некоторый период времени станция сделала 144 измерения. Каков информационный объем результатов наблюдений? Ответ укажите в байтах.
Ответ:
Question 4
Баллов: 1
Световое табло состоит из лампочек, каждая из которых может находиться в двух состояниях (включено или выключено). Сколько различных сигналов можно передать при помощи такого табло, если на нем 7 лампочек?
Ответ:
Question 5
Баллов: 1
В двенадцатиэтажном одноподъездном доме устанавливают цифровой домофон. Какое минимальное количество бит потребуется для кодирования номера каждой квартиры, если на каждом этаже 8 квартир?
Ответ:
Question 6
Баллов: 1
Световое табло состоит из лампочек, каждая из которых может находиться в двух состояниях (включено или выключено). Какое наименьшее количество лампочек должно находиться на табло, чтобы с его помощью можно было передать 196 различных сигнала?
Ответ:
Question 7
Баллов: 1
Метеорологическая станция ведет наблюдение за направлением ветра. Результатом одного измерения является одно из восьми возможных направлений, которое записывается при помощи минимально возможного количества бит. Станция сделала 216 измерения. Каков информационный объем результатов наблюдений? Ответ укажите в байтах.
Ответ:
Question 8
Баллов: 1
Алфавит некоторого языка состоит из 54 символов. Оцените информационный объем сообщения в БАЙТАХ длиной в 120 символов.
Ответ:
Question 9
Баллов: 1
Обычный дорожный светофор без дополнительных секций подает 6 видов сигналов (непрерывный красный, непрерывный желтый, непрерывный зеленый и мигающий красный,мигающий желтый,мигающий зеленый). Электронное устройство управления светофором последовательно воспроизводит записанные сигналы. Подряд записано 72 сигнала светофора. Оцените данный информационный объем в байтах.
Ответ:
Question 10
Баллов: 1
Алфавит некоторого языка состоит из 7 символов. Оцените информационный объем сообщения в БИТАХ длиной в 21 символ.
Ответ:
Question 11
Баллов: 1
Обычный дорожный светофор без дополнительных секций подает 6 видов сигналов (непрерывный красный, непрерывный желтый, непрерывный зеленый и мигающий красный,мигающий желтый,мигающий зеленый). Электронное устройство управления светофором последовательно воспроизводит записанные сигналы. Подряд записано 45 сигналов светофора. Оцените данный информационный объем в битах.
Ответ:
Question 12
Баллов: 1
Световое табло состоит из лампочек, каждая из которых может находиться в двух состояниях (включено или выключено). Какое наименьшее количество лампочек должно находиться на табло, чтобы с его помощью можно было передать 64 различных сигнала?
Ответ:

разаработайте програму НА ЯЗЫКЕ ПАСКАЛЬ которая запарашивает три строковые величины-взаимосвязаные прилагательное, существительное и глагол, а затем

печатает все варианты фраз с использованием введеных слов.

Пример входных данных Пример выходных данных

ЗЕЛЕНЫЕ ЗЕЛЕНЫЕ ЛИСТЬЯ РАСПУСКАЮТСЯ

ЛИСТЬЯ ЗЕЛЕНЫЕ РАСПУСКАЮТСЯ ЛИСТЬЯ

РАСПУСКАЮТСЯ ЛИСТЬЯ ЗЕЛЕНЫЕ РАСПУСКАЮТСЯ

ЛИСТЬЯ РАСПУСКАЮТСЯ ЗЕЛЕНЫЕ

РАСПУСКАЮТСЯ ЗЕЛЕНЫЕ ЛИСТЬЯ

РАСПУСКАЮТСЯ ЛИСТЬЯ ЗЕЛЕНЫЕ

Читайте также

Помогите))С клавиатуры вводится целое 4-х значное число.

Выдать сообщение о том, есть ли в этом числе четные цифры и указать их
количество.
НА ПАСКАЛЕ

1.С клавиатуры вводится действительное число a.Найти его квадратный корень.

2.С клавиатуры вводится действительное число p.Записать отдельно его целую часть C.
Помогите составить программу.

с клавиатуры вводится число х. если

с клавиатуры вводится число х. если остаток от деления х на 6 равен 2, то значение f(x)=4*x^2 если остаток от деления х на 6 равен 3, то значение f(x) = корень из х , если остаток от деления на 6 =0 то f(x) = x.


Написать программу в паскале используя операторы if и else . Нарисовать блок схему

С клавиатуры вводятся целые числа. Окончание ввода – число ноль. Ноль используется

только для указания окончания ввода и в остальных расчётах не участвует. Подсчитать
среднее арифметическое тех отрицательных чисел, которые оканчиваются на цифру «5».
Учесть, что таких чисел может не быть. PascalABC



Вы находитесь на странице вопроса "С клавиатуры вводится целое число, содержащие не более 7 цифр. Определить максимальную цифру в этом числе.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.