Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Задачка в Pascal: ввести целое число и определить, верно ли, что в его записи есть две одинаковые цифры. (Циклы с условием) Решение

5-9 класс

должно быть простым, потому что такие вещи, как массивы ещё не прошли. Скорее всего здесь будет использоваться while, div, mod.

Anita6 18 марта 2014 г., 11:58:21 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Rimmer1977
18 марта 2014 г., 12:34:28 (10 лет назад)

program gt;
var n,q,a1,a2,a3,a4,a5,a6,a7,a8,a9,a0:integer;
begin
read(n);
a0:=0;a1:=0;
a2:=0;a3:=0;
a4:=0;a5:=0;
a6:=0;a7:=0;
a8:=0;a9:=0;
while n>0 do
begin
q:=n mod 10;
n:=n div 10;
if(q=0)then a0:=a0+1;
if(q=1)then a1:=a1+1;
***********************
***********************
if(q=9)then a9:=a9+1;
end;
if(a0>1)or(a1>1)or....(a9>1)then writeln('yes')else writeln('no');
end.
буз массива как-то так получиться 

Ответить

Другие вопросы из категории

Пжл помогите.

Определите значение переменной z
после выполнения следующего фрагмента программы:
m:=13;
n:=21;
n:=2*m-n;
if m<=n then
p:=m+n
else
p:=4-m*n;

Напишите кто понимает
Как называют @ :

1) китайцы
2) немцы
3) итальянцы
4) французы

Читайте также

Программу надо написать в PascalABC, с использованием команд repeat и until. Ввести натуральное число и определить, какие цифры встречаются несколько раз

(с защитой от неверного ввода) или Ввести натуральное число и определить, верно ли, что сумма его цифр равна 10 (с защитой от неверного ввода).

Ввести

целое число и определить, верно ли, что в нём ровно 1 цифра
«9». (Кумир)

Напишите программу в Паскаль для решения задачи:

Ввести натуральное число и определить, верно ли, что сумма его цифр равна 10



Вы находитесь на странице вопроса "Задачка в Pascal: ввести целое число и определить, верно ли, что в его записи есть две одинаковые цифры. (Циклы с условием) Решение", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.