Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

даны два двумерных массива А и Б создать третий двумерный массив из максимальных элементов массивов А и Б как я понял нужно сравнить первый элемент

5-9 класс

первого и 1 эл второго массива а затем использовать их для создания третьего


женязахаров 25 дек. 2013 г., 1:30:57 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Korneichev
25 дек. 2013 г., 4:01:24 (10 лет назад)

#include <stdio.h>
char main(void)
{
  char A[5][5],B[5][5],C[5][5];
        int i,j, n = 5, m = 5;
printf(" Array A: ");
printf("\r\n");


    srand(time(0));
    for (i=0; i<n; i++)
      {
         for (j=0; j<m; j++)
          {
            A[i][j] = rand() %10;
            printf("%d ", A[i][j]);
           
          }
        printf("\r\n");
      }
printf(" Array B: ");
printf("\r\n");
srand(time(0));
    for (i=0; i<n; i++)
      {
         for (j=0; j<m; j++)
          {
            B[i][j] =1+ rand() %9;
            printf("%d ", B[i][j]);
               
          }
        printf("\r\n");
      }
    printf(" Array C: ");
   printf("\r\n");
for (i=0; i<n; i++)
      {
         for (j=0; j<m; j++)
          {
            if (A[i][j]>B[i][j])
                 C[i][j] = A[i][j];
                     else
                 C[i][j] = B[i][j];
               printf("%d ", C[i][j]);
          }
        printf("\r\n");
      }
 }

//////////////////////////// ПАСКАЛЬ /////////////////////////
Program asd;
Const n=3; m=3;
var A,B,C:array[1..n,1..m] of integer;
i,j:integer;
BEGIN
Writeln('Массив А: ');
For i:=1 to n do
begin
for j:=1 to m do
begin
A[i,j]:=Random(10);
Write(A[i,j]:3);
end;
Writeln;
end;
Writeln;
Writeln('Массив B: ');
For i:=1 to n do
begin
for j:=1 to m do
begin
B[i,j]:=Random(10);
Write(B[i,j]:3);
end;
Writeln;
end;
Writeln;
Writeln('Массив C: ');
For i:=1 to n do
begin
for j:=1 to m do
begin
if A[i,j]>B[i,j] then C[i,j]:=A[i,j]
else C[i,j]:=B[i,j];
Write(C[i,j]:3);
end;
writeln;
end;
END.


+ 0 -
Nyrapoiuh
25 дек. 2013 г., 4:51:20 (10 лет назад)

сравнивать их через if... then...else..

+ 0 -
федорчук
25 дек. 2013 г., 6:54:50 (10 лет назад)

Ты не указал на каком языке писал, поэтому я начал на С, сейчас кину на паскале, тебе ведь на нем скорее всего нужно

+ 0 -
79002997902
25 дек. 2013 г., 8:46:41 (10 лет назад)

и на С и на паскале

+ 0 -
Veronikaaa01
25 дек. 2013 г., 9:21:51 (10 лет назад)

Ну хорошо, удачи)

+ 0 -
Nfyz991
25 дек. 2013 г., 11:48:12 (10 лет назад)

вот как в паскале все жто добить

Ответить

Читайте также

1). Дан массив из n элементов (n >= 4). Подсчитать среднюю арифметическую второго и предпоследнего элемента массива.

2). Дан массив из n элементов. Написать программу подсчитывающую произведение элементов массива.

1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива.

2. Создать массив A из 10 элементов, заполненный случайным образом числами принадлежащих промежутку (0;20). Вывести полученный массив на экран. Вычислить количество элементов массива, значения которых не превышают среднее арифметическое значений его элементов.

1.Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел,найти количество отрицательных элементов массива.
3. Дан массив целых чисел,найти количество чётных чисел в массиве.

решить через паскаль через массивы)) 1.Дан одномерный массив из 10 элементов. Заменить все большие 7 члены массива числом 7. Найти количество

таких членов.

2.Дан массив из 10 элементов. Найти количество элементов с четными индексами.

3.Дан массив из 10 элементов. Найти наибольший элемент массива.

Дан целочисленный массив из 20 элементов. Элементы массива принимают значения от 0 до 10000 включительно. Написать программу, позволяющую найти и выв

ести максимальное значение среди трехзначных элементов массива, делящихся на 4. Если в исходном массиве нет трехзначного элемента, который делится на 4, то вывести сообщение о том, что такого числа нет.



Вы находитесь на странице вопроса "даны два двумерных массива А и Б создать третий двумерный массив из максимальных элементов массивов А и Б как я понял нужно сравнить первый элемент", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.