Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

3. Напишите программу на Паскале вывода значения true, если точка с заданными координатами (х,у) лежит внутри заштрихованной области и false, если не

10-11 класс

лежит.

гомка 28 марта 2014 г., 9:40:30 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Yana12345678910
28 марта 2014 г., 10:57:08 (10 лет назад)

var x, y: integer;

 

 

begin

  readln (x);

  readln (y);

  if (y > 0) and (y < 4) and (x < 4) and (x > -4) and (sqrt (x*x + y*y) < sqrt (4*4 * 4*4))

    then writeln ('true')

  else writeln ('false');

end.

  

если считать, что 1 клетка равна еденице.

  

Ответить

Другие вопросы из категории

помогите пожалуйста с информатикой!легкие задания,но не была на этой теме.

особенно обязательно вторые два задания.

13. Документ объёмом 16 Мбайт можно передать с одного компьютера на другой двумя способами.

А. Сжать архиватором, передать архив по каналу связи, распаковать.
Б. Передать по каналу связи без использования архиватора.
Какой способ быстрее и насколько, если:
• средняя скорость передачи данных по каналу связи составляет 221 бит в секунду;
• объём сжатого архиватором документа равен 25% исходного;
• время, требуемое на сжатие документа, – 12 секунд,
• на распаковку – 3 секунды?
В ответе напишите букву А, если быстрее способ А, или Б, если быстрее способ Б. Сразу после буквы напишите число, обозначающее, на сколько секунд один способ быстрее другого. Так, например, если способ Б быстрее способа А на 23 секунды, в ответе нужно написать Б

Читайте также

Составить программу, по которой выведется значение true, если точка с заданными координатами (x,y)

лежит внутри заштрихованной области и false

Здравствуйте, уважаемые :) Помогите пожалуйста составить программу на Паскале. Спасибо огромное!

1. Напишите программу формирования и вывода массива размером 6x3, каждые три последовательных элемента в строке которого составлены по следующему правилу:
1-й — равен случайному числу;
2-й — равен целой части квадратного корня из предыду щего элемента;
3-й-равен сумме двух предыдущих элементов.

Пожалуйста помогите!!!

Напишите программу на Паскаль которая даст ответ попадет точка в заштрихованную область или нет



Вы находитесь на странице вопроса "3. Напишите программу на Паскале вывода значения true, если точка с заданными координатами (х,у) лежит внутри заштрихованной области и false, если не", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.