Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Задано одномерный масив D с десятью елементами целых чисел. Поставьте все элементы по возрастанию и выведете результаты на экран

5-9 класс

Qikki 19 дек. 2014 г., 13:26:12 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lra908976
19 дек. 2014 г., 14:45:23 (9 лет назад)

const m = 10;
var
  a: array[1..m] of integer;
  i, j, tmp: integer;
begin
  for i := 1 to m do begin
    a[i] := random(100);
    write (a[i], ' ');
  end;
  writeln;
  for i := 1 to m-1 do
    for j := 1 to m-i do
      if a[j] > a[j+1] then begin
        tmp := a[j];
        a[j] := a[j+1];
        a[j+1] := tmp
      end;
  for i := 1 to m do
    write (a[i], ' ');
end.

Ответить

Другие вопросы из категории

Запросить стороны треугольника и определить,является ли он разносторонним,равносторонним или равнобедренным. Учесть: третья сторона не должна превышать

сумму двух других,иначе треугольник не существует. Задача на тему "Программирование ветвлений на Паскале".

Коля при подключении Интернета выбрал тарифный план, который по-

зволяет загружать 100 Мбайт информации за 1 секунду. Придя домой, он
поставил на скачивание файл объёмом 204800 Кбайт. Через сколько секунд
будет скачан файл?

напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех чисел кратных 7 и оканчивающихся на 0. Программа получает на

вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0- признак окончания ввода, не входит в последовательность), Количество чисел не превышает 1000. Введенные числа не превышают 30000. Программа должна вывести одно число: сумму всех чисел, кратных 7 и оканчивающихся на 0. Программу надо написать в Pascal

Читайте также

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

1.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество.

2.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50. Заменить все четные элементы на их квадраты, а нечетные удвоить.

а)Одномерный массив A заполнен десятью случайными целыми числами от 1 до 20. Напишите программу вывода элементов массива в обратном порядке.

б)Напишите программу, которая массив из 20 элементов заполнит неповторяющимися целыми числами и выведет на экран элементы с нечетными индексами.

Массивы. СРОЧНО!!!!! ПОЖАЛУЙСТА!!!!! - 20 баллов

1. Задать через датчик случайных чисел одномерный
вещественный массив V[1..20]
и отсортировать его по возрастанию, полученный массив вывести на экран.

1) составьте программу заполнения элементов массива [1..10 ] случайнымии целыми числами на отрезке [ 0;35 ] и вывода на экран нечетных элементов и

кратных числу 3.

2) составьте программу , которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 100 и выводит на экран среднее арифмитическое элементов массива



Вы находитесь на странице вопроса "Задано одномерный масив D с десятью елементами целых чисел. Поставьте все элементы по возрастанию и выведете результаты на экран", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.