Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Помогите пожалуйста:

5-9 класс

1)В одномерном массиве А(15) найти процент отрицательных элементов.
2)

Dvoecnic 19 янв. 2015 г., 18:50:44 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Аня77777
19 янв. 2015 г., 20:03:50 (9 лет назад)

1)
uses crt;
var a:array [1..15] of integer;
     i,k:integer;
begin
  randomize;
  k:=0;
  for i:=1 to 15 do
    begin
      a[i]:=random(10)-3;
      if (a[i]<0) then inc(k);
      write (a[i],' ');
    end;
  writeln;
  writeln (k/15*100,'%');
end.

2)
uses crt;
var a:array [1..20] of integer;
     i:integer;
begin
  randomize;
  for i:=1 to 20 do
    begin
      a[i]:=random(30);
      write (a[i],' ');
    end;
  writeln;
  for i:=1 to 20 do
    if (a[i] mod 10 = 3) then write (a[i],' ');
end.

3)
uses crt;
var a:array [1..20] of integer;
     i:integer;
     k:longint;
begin
  randomize;
  k:=1;
  for i:=1 to 20 do
    begin
      a[i]:=random(30);
      write (a[i],' ');
      if (a[i]>9) and (a[i]<100) then k:=k*a[i];
    end;
  writeln;
  writeln (k);
end.

4)
uses crt;
var a:array [1..30] of integer;
     i:integer;
     flag:boolean;
begin
  randomize;
  for i:=1 to 30 do
    begin
      a[i]:=random(30);
      write (a[i],' ');
    end;
  writeln;
  flag:=true;
  for i:=1 to 29 do
    if (a[i]>a[i+1]) then
     begin
       flag:=false;
       break;
     end;
  writeln (flag);
end.

Ответить

Читайте также

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Даны натуральное число n и вещественные числа a1, a2, ..., an. Определить среднее арифметическое вещественных чисел...

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

Как пройти 7 уровень в час кода ам няма помогите пожалуйста!!

Как пройти 9 уровень в час кода ам няма помогите пожалуйста!!

Люди Люди Люди если вы читаете это сообщение значит вы просто обязаны помочь! пожалуйста если у вас есть паскаль помогите пожалуйста решить первое и

второе задание ну или хотя бы только первое .Это вопрос жизни и смерти помогите пожалуйста P.S задание во вложениях.заранее спасибо и знайте если вы поможете значит вы самый добрый и отзывчивый человечек!)



Вы находитесь на странице вопроса "Помогите пожалуйста:", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.