Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Даны числа x,y и z. Составьте программу, которая возводит в квадрат те из них, которые не отрицательные

5-9 класс

Bazilevskajadia 26 июля 2015 г., 11:28:23 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
хорошийдруг
26 июля 2015 г., 12:27:10 (8 лет назад)

var
  x, y, z : real;
begin
  read (x, y, z);
  if (x > 0) then x := sqr (x);
  if (y > 0) then y := sqr (y);
  if (z > 0) then z := sqr (z);
  write (x, ' ', y, ' ', z);
end.

Ответить

Другие вопросы из категории

помогите пожалуйста(

1) периметр треугольника равен P. длины двух сторон равны между собой. найти длины сторон.
2) Вводится N целых чисел, найти количество чисел, которые больше нуля и кратны числу 5.

На языке Паскаль(АВС)

Помогите плз срочно по Информатике. 1) Каковы значения чисел: 0,1Е+2; -35,5Е-1; 4,0Е-1; 55,0Е+0. 2)Запишите числа в формате mEp, где

m<1:65; 125,5; 458,2; 250.

3)Обьявите переменные p,3- как действительные числа; Word1.

Читайте также

Вариант № 2 1)Подсчитать сумму квадратов всех отрицательных и четных чисел из 10 вводимых. 2) Даны натуральные числа от 35 до 87.

Найти и напечатать те из них, которые при делении на 7 дают остаток 1, 2 или 5.

3)Дано целое число а и натуральное (целое неотрицательное) число n. Вычислить а в степени n, используя в программе лишь операцию умножения.

4)Введите последовательность из n целых чисел. Найти наибольшее из всех отрицательных чисел. Вывести его значение и порядковый номер.

5)Вычислите: 99-97+95-93+91-89+....+7-5+3-1.

6)Доказать (путем перебора возможных значений), что для любых величин А, В, С типа Boolean следующая пара логических выражений имеет одинаковые значения (эквивалентны): A OR (B AND C) и (A OR B) AND (A OR C).

ПОМОГИТЕ ПОЖАЛУЙСТА С ДВУМЯ ЗАДАЧАМИ НА ЯЗЫКЕ PASCAL: 1)даны 2 числа, заменить второе число нулем, если оно не меньше первого и оставить его

прежним,если это не так. 2)Даны 3 числа, возвести в квадрат те из них, значения которых не отрицательны, а отрицательные оставить без изменений



Вы находитесь на странице вопроса "Даны числа x,y и z. Составьте программу, которая возводит в квадрат те из них, которые не отрицательные", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.