Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

даны три действительных abc. возвести в квадрат те из них которые не положительные

5-9 класс

КоролеваВетров 24 окт. 2014 г., 10:03:24 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vladmitrop
24 окт. 2014 г., 12:19:13 (9 лет назад)

var

  a, b, c: real;

 

begin

  writeln('Введите числа a, b, c');

  readln(a, b, c);

  if a <= 0 then a:= sqr(a);

  if b <= 0 then b:= sqr(b);

  if c <= 0 then c:= sqr(c);

  writeln('a = ', a, ', b = ', b, ', c = ', c);

end.

Ответить

Другие вопросы из категории

ребят, помогите пожалуйста, ну ооочень нужно, от этого зависит аттестуют меня или нет, заданий правда много, и пожалуйста, не пишите херню либо очень

мало
эти задания нужно сделать циклами while и for, т е чтобы получилось 12 программ

1. Составьте программу вычисления значения функции: y=7x^2+1/x^2-16
2. Составьте блок-схему алгоритма и программу расположения четырех чисел в порядке возрастания.
3*. Составьте программу, определяющую вид треугольника по трем его сторонам A, B, C.

4. Составьте блок-схему алгоритма и программу вывода на экран всех трехзначных чисел, кратных 7.
5. Составьте блок-схему алгоритма и программу вычисления суммы всех трехзначных чисел, кратных 13.
6*. Составьте программу вывода на экран таблицы степеней 2ⁿ, где 0 ≤ n ≤ 10.

я вас просто умоляю, напишите, пожалуйста

2. От разведчика была получена следующая шифрованная радиограмма, переданная с использованием азбуки Морзе:

_ . . . . _ _ . . . _ _ _ _ . .
При передаче информации было потеряно разбиение на буквы, но известно, что в радиограмме использовались следующие буквы:
Н:_.
З:_ _ ..
В: . _ _
У: . . _
С: . . .
Определите текст радиограммы.

Читайте также

ПОМОГИТЕ ПОЖАЛУЙСТА С ДВУМЯ ЗАДАЧАМИ НА ЯЗЫКЕ PASCAL: 1)даны 2 числа, заменить второе число нулем, если оно не меньше первого и оставить его

прежним,если это не так. 2)Даны 3 числа, возвести в квадрат те из них, значения которых не отрицательны, а отрицательные оставить без изменений

Вариант № 2 1)Подсчитать сумму квадратов всех отрицательных и четных чисел из 10 вводимых. 2) Даны натуральные числа от 35 до 87.

Найти и напечатать те из них, которые при делении на 7 дают остаток 1, 2 или 5.

3)Дано целое число а и натуральное (целое неотрицательное) число n. Вычислить а в степени n, используя в программе лишь операцию умножения.

4)Введите последовательность из n целых чисел. Найти наибольшее из всех отрицательных чисел. Вывести его значение и порядковый номер.

5)Вычислите: 99-97+95-93+91-89+....+7-5+3-1.

6)Доказать (путем перебора возможных значений), что для любых величин А, В, С типа Boolean следующая пара логических выражений имеет одинаковые значения (эквивалентны): A OR (B AND C) и (A OR B) AND (A OR C).



Вы находитесь на странице вопроса "даны три действительных abc. возвести в квадрат те из них которые не положительные", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.