Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Будьте добры, помогите решить.

5-9 класс

1. Написать программу, которая считает количество 0 в заданном шестизначном числе.

Пример работы программы:

Введите число: 205408
Кол-во нулей в числе: 2

Irinka97 29 авг. 2015 г., 11:05:24 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Anuraanita
29 авг. 2015 г., 12:48:37 (8 лет назад)

Строками. Pascal
var a,k,m:integer;i:string;
begin
k:=0;
read (a);
if (a div 1000000<1) and (a div 100000>1)then
begin
str(a,i);
for m:=1 to length(i) do
begin
if (i[m]='0') then k:=k+1;
end;
end
else
begin
writeln ('Неверный ввод');halt;end;
writeln (k);
end.


Ответить

Другие вопросы из категории

Теория вероятности: На семинар приехали: 6 ученых из Голландии, 5 из Италии, 4 из Чехии. Порядок показа их докладов

определяет жребий. Какова вероятность того, что 4-ым окажется доклад ученого из Голландии?

помогите пожалуйста(

1) периметр треугольника равен P. длины двух сторон равны между собой. найти длины сторон.
2) Вводится N целых чисел, найти количество чисел, которые больше нуля и кратны числу 5.

На языке Паскаль(АВС)

Читайте также

1. Написать программу, которая спрашивает «Который час?» и, в зависимости от введенного времени, выводит на экран приветствие: «Доброе утро», «Добрый

день», «Добрый вечер», «Спокойной ночи».
2. Составьте программу, которая вычисляет оптимальный вес пользователя, сравнивает его с реальным весом и выдает рекомендации о необходимости поправиться или похудеть. Оптимальный вес вычисляется по формуле: рост (в сантиметрах) – 100.
Помогите решить 2 задачи

Помогите решить задачи , Плииииз !!!! 1)Семья , состоящая из дедки , бабки , внучки , жучки , кошки , выращивает репу . Потребуется ли им привлечение

мышки для сбора урожая ИСХОДНЫЕ ДАННЫЕ ______________________ 2)Малыш и карлосон решили по-братски разделить два сладких орешка-болльшой и маленький . Как это сделать ? Помогите плиз , заранее спасибо :) надеюсь на вас ! Просто я непоняла что с исходными данными делать .

PASCAL. нужна помощь. ПОЖАЛУЙСТА помогите решить задачу в PASCAL (если рОЧЕНЬ нужна помощь. ПОЖАЛУЙСТА помогите решить задачу в PASCAL (если решиш - проси

что угодно, помогу)Вот задача - Под конец учебного года ученики 11 класса решали понять у кого же из них будет самый высокий средний балл ? Известно , что - в классе учится 14 учеников, - Сумма всех средних баллов аттестата = 100.Известно также , что первый ученик имел средний балл, который составляет 1/ 12 суммы всех средних баллов. Второй ученик - на 0,15 % больше, чем первый ученик , но на 1,75 % меньше , чем третий ученик . Средние баллы аттестатов двух сестер были равными среднему арефметичному оценок вышеупомянутых учеников , разделенном на 1.5 . Четвертый ученика на конец года имел такой же балл , как и первый ученик , но на 5% меньше , а остальные ученики - имели равные баллы .Какой средний балл на конец года получил каждЫй?

Пожалуйста,помогите решить задачу по информатике:

Маша набирает текст со скоростью 40 символов в минуту,а Катя- 20 символов в минуту.Через какое время девочки введут одинаковое количество символов,если Катя начала набирать текст на 5 минут раньше?
Нужно решить без x! Спасибо



Вы находитесь на странице вопроса "Будьте добры, помогите решить.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.