Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите срочно пожалуйста

5-9 класс

MrsSmi 04 мая 2014 г., 21:48:33 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nastena9692
04 мая 2014 г., 23:58:40 (9 лет назад)

Посмотрим, какой будет порядок цветов ночью  через 1,2,3,... дней.
1) GCV -> GVC -> VGC
2) VGC -> VCG -> CVG
3) CVG -> CGV -> GCV и мы получили первоначальную расстановку цветов.
Следовательно, всего существует три варианта расстановок и они повторяются раз в три дня. Если задано N дней, достаточно найти остаток целочисленного деления на 3 (т.е. 0, 1, 2) и этим остаткам будут соответствовать варианты VGC, CVG, GCV.

var
  fIn, fOut: Text;
  n: integer;
  s: string;

begin
  s := 'GCV';
  Assign(fIn, 'input.txt');
  Reset(fIn);
  Read(fIn, n);
  Close(fIn);
  case n mod 3 of
    0: s := 'VGC';
    1: s := 'CVG';
    2: s := 'GCV'
  end;
  Assign(fOut, 'output.txt');
  Rewrite(fOut);
  Write(fOut, s);
  Close(fOut);
  writeln('Работа завершена!')
end.

Ответить

Другие вопросы из категории

Читайте также

Помогите срочно пожалуйста
Помогите срочно пожалуйста !!!

Переведите из одной единицы измерения в другую

помогите срочно пожалуйста
Помогите срочно пожалуйста

Ограничения [Время: 1000ms, Память: 128MB, Сложность: 2%]
Даны два целых числа. Вывести меньшее из них.
Входные данные:
Во входном потоке в первой строке через пробел заданы целые числа A и B (-30000 < A,B < 30000), A неравно B.

Выходные данные:
В выходной поток вывести единственное целое число.

Пример входного файла (input.txt):
-30000 45
Пример выходного файла (output.txt):
-30000



Вы находитесь на странице вопроса "Помогите срочно пожалуйста", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.