Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите с информатикой

5-9 класс

Lasora 29 янв. 2015 г., 12:48:22 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Zzzvezda
29 янв. 2015 г., 14:03:50 (9 лет назад)

var
a,s,i:integer;
begin
s:=0;
for i := 1 to 10 do
begin
read(a);
s:=s+a;
end;
write(s);
end.

 

 

 

var
a:array[1..15] of integer;
i,p:integer;
s:real;
begin
p:=1;
for i := 1 to 15 do
begin
read(a[i]);
s:=s+a[i];
p:=p*a[i];
end;
s:=s / 15;
writeln(a[7]+a[1]);
writeln(a[9]-a[3]);
writeln(s:5:3);
writeln(p);
end.

 

 

 

  

var
p,h,sum,s,i,n:integer;
a:array of integer;
begin
readln(n);
selength(a,n);
p:=1;
for i := 1 to n do
begin
read(a[i]);
if odd(i) then
p:=p*a[i];
end;
for i := 1 to n div 2 do
begin
sum:=sum+a[i];
s:=s+a[i*2];
if not odd(a[i*2]) then
h:=h+a[i*2];
end;
writeln(sum);
writeln(s);
writeln(p);
writeln(h);
end.

 

 

 

 

 

var
a:array[1..9] of real;
s,p:real;
i:integer;
begin
p:=1;
for i := 1 to 9 do
begin
read(a[i]);
s:=s+a[i];
p:=p*a[i];
end;
writeln(s:5:3);
writeln((s/9):5:3);
writeln(p:5:3);
end.

 

 

 

 

 

 

Ответить

Другие вопросы из категории

Выразить в килобайтах:
составить программу в паскале!!! ПОЖАЛУЙСТА!!! СРОЧНО!!! 9 класс!!! На ввод в программу натурального числа из диапазона [1, 25] программа выводит это

число и согласованное с ним слово «книга». Например, на ввод числа 1 программа выводит «1 книга», на ввод числа 2 — «2 книги» и т. д.

как посмотреть историю
1. напишите программу которая вводит значения 3 переменных a и b с приглашениями к ввожу каждой переменной и выводит их разность. Приглашение и ввод

каждого значения произвести в отдельных строках. Ввод сопроводить пояснениями.

2. Нипишите программу ввода значений A,B,C в одной строке и выведите результат выражения A*(B/3,14)+(C*3) в отдельной строке.

3. написать программу

а:=5; b:=6

найти: сумму, разность, частное и произведение

Читайте также

Пожалуйста помогите по информатике

1) исключи лишнее:
а)микрофон, б)колонки, в) наушники , г) монитор
2)исключи лишнее:
а)процессор, б) монитор, в)клавиатура, мышь
3)установите соответствие. Устройство ПК:
1. клавиатура
2. модем
3.центральный процессор
назначение устройств:
а)передача цифровой информации через каналы связи
б)хранение информации
в)обеспечение общего управления ПК, осуществление вычислений по программе, хранящейся в оперативной памяти
г)визуальное отображение информации, находящейся в оперативной памяти
д)ввод алфавитно-цифровых символов
6.Раздели на группы и дай название каждой группе:
а)принтер,б)сканер,г)мышь,д)проектор,е)веб камера,ж)процессор,з)колонки,и)микрофон, к) монитор
Пожалуйста помогите очень срочно.

Помогите с информатикой


Вы находитесь на странице вопроса "Помогите с информатикой", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.